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Hyperwave User’s Guide - Introduction

INTRODUCTION
The Hyperwave User’s Guide is intended for people who need to upload or edit documents on a
Hyperwave Information Server or for those who want a general introduction to Hyperwave’s
functions and features. Chapter 1 is a basic overview of Hyperwave’s most important architectural
concepts. It is meant to give new users a feel for what they can expect when working with the
server and to show them how the server can simplify their information management tasks.

Chapter 2 describes all aspects of browsing and authoring with Hyperwave. It tells you how to
upload documents using Web browsers such as Netscape and Microsoft Internet Explorer and
how to use the Hyperwave Publishing Wizard to upload entire collections of documents. How to
use Hyperwave’s advanced search facilities to find information on the server and how to use the
Open Document Management API (ODMA) interface to edit documents on the server is also
described.
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1 ARCHITECTURAL CONCEPTS

1.1� STATIC AND DYNAMIC ARCHITECTURES

Many intranet and Internet Web servers use a static, file-based architecture of HTML pages
logically connected by hyperlinks. In contrast, Hyperwave Information Server generates HTML
pages and provides additional structuring elements that enable automatic generation of hyperlinks,
without the need for programming.

1.1.1� STATIC STRUCTURE

In the classical hypertext "data model" of the Web shown in Figure 1, documents are connected by
hyperlinks. The links are statically contained within the documents, and refer to other documents
by URLs. Activating a hyperlink essentially jumps from one document to another.

Figure 1: The Hypertext "data model"

In this chapter you will learn how Hyperwave’s advanced features for reading and
authoring can help you achieve your daily business goals more efficiently. You will
also learn how Hyperwave Information Server enables system administrators to
harness the complexity of intranet applications.
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The rapid growth of the Web owes much to this simple architecture, because it makes it extremely
easy to set up a small Web site. However, as the site grows, it can often become unmanageable. We
refer to this phenomenon as the "GOTO syndrome", because the semantics of a hyperlink ("jump
to document") and the infamous "GOTO" statement in early computer programming languages
("jump to statement") are fairly similar, as are the problems arising from it. However, while these
problems were eliminated in structured programming languages decades ago, we are just
beginning to attack them now in information management.

The simple hypertext approach shown in Figure 1 has the following shortcomings:

· Navigating large hypertexts is difficult. As the number of documents (and their hyperlinks)
grows, users find it increasingly hard to get an overview of available information, to find the
information they are looking for, and to find information again. Further, users find it
difficult to locate new or updated information, to learn how much information exists on a
certain topic, to make sure that they see every piece relevant to a certain topic, and to
recognize outdated information. This is known as the "lost in hyperspace" syndrome.

· For authors (and large intranet sites will always require collaboration of a multitude of
authors) there are more problems. One is link consistency: When you delete a document,
the links in other documents pointing to the document just deleted break; the result is an
error and a frustrated user.

· A less visible link management problem is known as "orphan": a document becomes
unreachable when the last link pointing to it is removed. This condition is relatively
difficult to detect. Both problems (broken links and orphans) become significant in a
multi-author environment, because the actions of one author (deleting a link or a
document) can lead to problems with another author’s documents (which can become
orphans or contain broken links), without the other author ever knowing of the problem.

· Similarly, when inserting a new document A, it is required to edit at least one other
document B, in order to make a link to the new document. This is not only additional
work, it also means that authors have to have write access to document B, which would also
allow them to modify the contents of B or remove links to other documents. This means
that the hypertext network approach shown in Figure 1 cannot support a security model
suitable for collaborative authoring.

· The simple, "GOTO"-like navigation paradigm of hypertext makes it impossible to
combine individual documents to self-contained information components, which can be
re-used in different contexts in slightly different ways (customized views).

The result of all this is a Web of documents that looks like a "giant spaghetti bowl", as Robert
Cailliau of CERN, one of the Web’s inventors, once called it. In practical terms, this means lots of
maintenance effort, inconsistency, and chaos.

1.1.2� DYNAMIC STRUCTURE HELPS

In modern programming languages such problems have been eliminated by the introduction of
structured programming and abstract data types. In a similar fashion, Hyperwave Information
Server eliminates the above problems by introduction of structural elements and an object
repository.

When you look at any Web content, you may realize that there are two logically distinct groups of
hyperlinks used:

· structural (sometimes also called organizational) hyperlinks are used to structure (organize)
the content. This type of hyperlink is commonly found in tables of contents, navigation
bars, frames, "next", "previous", "up", and "home" links.

STATIC STRUCTURE
PROBLEMS

SPAGHETTI WEB

STRUCTURAL AND
REFERENTIAL HYPERLINKS
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· referential ("real") hyperlinks are cross-references, emanating from areas (e.g., words) in a
document (e.g., a text document), such as "see also section 4". This is what hyperlinks were
originally intended for.

Traditional Web architectures do not distinguish between the two types of hyperlinks. Hyperwave
Information Server takes a different approach: structural hyperlinks are maintained by the system,
completely automatically and dynamically, rather than by the authors. This dramatically reduces
the number of hyperlinks authors need to be aware of 1.

To achieve this, Hyperwave Information Server introduces the concept of abstract structural
elements called containers. A container contains a number of other elements, which could be
documents or other containers. There are a number of predefined container classes: Collection,
Sequence, MultiCluster, and AlternativeCluster.

Figure 2 shows the simplest container class, called collection. A collection is very much like a
directory or folder in a hierarchical file system. However, an item may be a member of more than
one collection (such as the text item in Figure 2). When accessing a collection (with a URL), it is
visualized as a menu-like table of contents2, i.e. the user is given a choice of sub-elements. Of
course the sub-elements could again be collections. This defines the so-called collection hierarchy.

Figure 2: The "Collection" structure element

Let’s take a look at the big advantages of the structured approach over the "spaghetti web":

The collection listing (menu) is dynamically generated by the system. This means that it is always
consistent. When you delete something, the corresponding entry or entries are also removed.
When you insert something into a collection, its entry appears in the collection listing. Since
information objects inserted into Hyperwave Information Server's repository always have to be put
into at least one collection, there can be no orphaned objects.

All this is done with simple "insert" and "delete" operations. There is no need to manually
maintain a table of contents, and no opportunity to make a mistake in doing so, such as forgetting
to update a link when you move an object. We will look at a specific example to illustrate this later.

Unlike in the hypertext model, there is no need to edit other people's documents in order to insert
a new document. This is a precondition for a strong security model which supports collaborative
authoring.

While there is the possibility3 to override the collection's automatic table of contents menu with a
manually designed page, the majority of a large Web site's collections will use the automatically
generated collection listings in order to reduce the overall graphic design work required. For the
users this means a consistent way of navigating the hierarchy.

�����������������������������������������������������������������������

1 We will see later that Hyperwave Information Server also manages referential hyperlinks, but differently.
2 The visual presentation is highly customizable, so your menus do not all need to look the same.
3 So-called collection heads allow you to define a document which should be visualized whenever the collection is opened,
optionally bypassing the automatically generated collection listing for a graphically rich visualization of the collection.

STRUCTURE ELEMENTS

CONSISTENCY

REDUCED MAINTENANCE
EFFORT

SECURITY

NAVIGATION
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In addition, Hyperwave Information Server also supports a tree-like navigation of the collection
hierarchy (similar to the Windows Explorer). This makes it very easy to navigate (and also
manipulate, if you have the appropriate access rights) the collection hierarchy.

The collection hierarchy can also be seen as a classification of the information in the system. Since a
document or collection may be member of a number of collections, such a classification need not
be unique. There can be multiple views (classifications) of the same information space4. After all,
why should a company’s top management have the same view as a specialized employee?

Unlike the unorganized hypertext model shown in Figure 1, the collection hierarchy gives us the
ability to define scope in terms of the logical structure of the information space. For example, we
may specify that a certain search operation should be restricted to a certain part of the information
space, i.e. only documents which are contained in a certain collection. Likewise, we can use the
scope to perform arbitrary operations on a certain part of the information space, or to define
access permissions.

The collection listing is not manipulated when you insert an element. Rather, it is generated on the
fly when a user accesses the URL associated with the collection, taking into account such things as
a sort order associated with the collection (you can sort by any metadata element of the members,
see page 9), identity of the user (you never see items you are not allowed to see, not even in the
collection listing), validity of the member item (objects can be made invisible before and after
specified times), and user’s preferences. Essentially, this means that for different users the
collection listing may look different.

Of course, it now becomes possible to re-use certain parts of the collection hierarchy in many
different places. For example, in a Web Based Training application, parts of a lesson may appear in
multiple lessons. Still, they are not physical copies, but the very same items.

These advantages will become even more obvious when we discuss the other container classes
below.

1.1.3� MORE CONTAINER CLASSES

In addition to the collection, there is a small number of other predefined container classes5.

A Sequence is similar to a collection. The difference is that in addition to the collection listing, the
system also generates "next" and "previous" links between the member elements. This means that
users need not press the "back" button on their browsers and select the next item manually when
they want to look at all the elements one after the other. Sequences are useful in situations where a
set of documents (pages) should be visited in a certain order, such as in many Web Based Training
applications.

�����������������������������������������������������������������������

4 Please note that for reasons of consistency, it is important that the individual documents are identical, not copies.
5 While it is possible in principle to define your own container classes in Hyperwave Information Server 4, future versions
will have more elegant means to (re)define document and container classes.

MULTIPLE VIEWS

SCOPE

HIGHLY DYNAMIC

REUSABLE COMPONENTS

SEQUENCE
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Figure 3: The "Sequence" structure element

Figure 3 shows the logical structure of a sequence of 7 HTML documents. As an example of how
significant the reduction of maintenance effort for this structure is, compared to other Web server
based solutions, consider the following scenario: We want to insert a new HTML document
between documents 4 and 5 (see Figure 3). With a standard Web server, where the hyperlinks are
statically stored within the HTML documents, we would have to perform the following operations:

1. Edit the table of contents document and insert a new hyperlink to the new document.

2. Edit document number 4 and update the "next" hyperlink to point to the new document
instead of the (old) document number 5.

3. Edit the (old) document number 5 and update the "previous" hyperlink to point to the
new document instead of document number 4.

4. Edit the new document and insert hyperlinks to

a) the table of contents ("up"),

b) document number 4 ("previous"), and

c) (old) document number 5 ("next").

5. Copy the new document to its correct place on the server

In other words: in addition to physically moving the new document to the server, we would have
to create or update 6 hyperlinks in 4 different documents. Needless to say, this is a lot of effort, and
there are a lot of opportunities to introduce errors or inconsistencies. The same effort is required
when removing a document. Also, it means that whoever is supposed to insert information into
the sequence must have write access rights to all other documents of the sequence and the table of
contents.

With Hyperwave Information Server, we would perform only one operation:

1. Insert document into sequence

This operation physically copies the document to the server, and inserts it into the sequence,
taking into account the sort order defined for this sequence (e.g., "alphabetically by title of the
document"). The rest (maintaining the link structure) is done automatically. In fact, it is not done
at all on insertion, but the links are generated on the fly when users access the sequence or its
elements. When you want to remove a document from a sequence, you just delete it. The
navigation is adapted automatically.

Obviously, this reduces maintenance effort significantly. Additionally, the dynamic generation of
hyperlinks between the elements enables a number of features not possible with static HTML:

AN EXAMPLE

new

1          2          3            4           5           6           7
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· The identical documents can be members of a number of sequences ("multiple views").
The "next", "previous", and "up" links are adjusted depending on where (from what
sequence) the user came from. There is no need to create physical copies of documents.

· Similarly, you can use the sequence within another sequence. This means that your
sequence becomes a component which may be re-used in different contexts.

· Access permissions are taken into account. When a user is not allowed to see, e.g.,
document number 3, the "next" link on document number 2 points to document number
4, and the table of contents would not list document number 3. The same would be true if
document number 3 had expired. In other words, the user would never know that
document number 3 even existed.

· Every user who has been granted write permission to the sequence object can insert
information into the sequence, without having to modify other people’s documents. This
means that people can collaboratively and securely6 populate the sequence.

Please note that the features listed above do not only apply for sequences, but for any class of
container.

While both collections and sequences display a menu of the elements contained, the MultiCluster
combines all its elements into one document and displays the result. As always, this is done
dynamically when a user visits the MultiCluster, so that sort order, expiration time, access
permission, and user preferences are taken into account.

MultiClusters are useful in situations where you want to combine relatively small pieces of
information (paragraphs, images, etc.) into one document. The individual pieces can be supplied
by different authors (so that users can collaboratively create the large document without getting in
each other’s way), can have different access permissions (e.g., some paragraphs should only be
seen by privileged users), and can be reused in other contexts.

Let us look at a simple example, a calendar of events:

Each event is a small document, either created by a customized entry dialog or an HTML editor.
The "expiration date" attribute is set to the date of the event. The event listing is a MultiCluster,
which is sorted by expiration date. This has the effect that we get a single event listing sorted by
date of the event. Listing of old events is automatically suppressed by the system (because expired
objects are not displayed) without human intervention, so it looks as if the listing were maintained
daily. Note that users with write access to the MultiCluster may add events, and edit or remove
"their" events; there is no need to ask a dedicated Webmaster to edit the event listing, or to grant
everybody write access to the whole listing.

The AlternativeCluster is similar to the MultiCluster, but instead of returning a combination of all
elements, the AlternativeCluster returns only one of its elements. The selection of this element is
based on matching user preferences with attribute values of the elements. While it is in principle
possible to select the element based on any attribute, the following types have proven to be useful:

· Select by language: Use the user’s language preferences to decide what document to show.
In this case, the AlternativeCluster contains a number of translations of the same
information, which is quite useful for managing multilingual applications.

· Select by MIME Type: Use the user’s preferred MIME Type settings to select a document.
In this case, the AlternativeCluster contains the same information in different encodings
(MIME Types), e.g., MS Word, PDF, and HTML. This is useful when the users do not have
the same functionality at their client terminals (e.g., some have UNIX workstations where
MS Word is not available), or need to perform different tasks with the information.

· Select by Quality: Use the user’s preferred Quality settings to select a document. In this
case, the AlternativeCluster contains the same information in various encodings or qualities
(specified by the Quality attribute). For example, an image may be available in lossless
compression (e.g., GIF) and various quality levels of lossy compression (e.g., JPEG). This is

�����������������������������������������������������������������������

6 I.e., you can insert a document with write access only for yourself, so that others cannot tamper with your information.

MULTICLUSTER

EXAMPLE

ALTERNATIVECLUSTER

EXAMPLES
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useful in situations where the users have different bandwidth available (e.g., modem vs.
LAN) and want to trade quality for speed.

All kinds of combinations of structural elements are possible (while some combinations are more
useful than others). For example, an application might be built as a collection of sequences of
MultiClusters of AlternativeClusters of documents. Figure 4 shows another example.

Figure 4: Structure elements combined with hyperlinks

Figure 4 also shows an important philosophical aspect of building applications with Hyperwave
Information Server. The bold arrows represent "real", referential hyperlinks, which may of course
be combined with structural elements. The goal is to replace the structural (organizational)
hyperlinks by a combination of structural elements as much as possible, and use hyperlinks only
for cross-references. This has the tremendous advantage that the system itself takes care of
generation and maintenance of structural hyperlinks, with all the added benefits of dynamic link
generation. It also means that the site can easily be restructured later, without editing any
documents.

1.1.4� SEPARATE INFORMATION AND PRESENTATION

Another important feature that comes with the use of structural elements is the clear separation of
information (content) and its presentation (layout, navigation). The document management
community has traditionally separated content and layout (just think of the concepts of SGML
and now XML, where the document defines the content and a style sheet defines the layout). The
importance of this distinction has been neglected in the Web, since HTML defines both content
and its presentation (including navigation).

Hyperwave Information Server lets authors focus on supplying the content, and the presentation
(with layout and navigation) is performed by the system, according to the exact specifications of
system administrators.

What are the advantages of having content and presentation separated?

· It is absolutely necessary when you want to enable ordinary users to provide content, which
is important in making intranets work and creating knowledge management applications.
Otherwise, such users would have to worry not only about the information itself (where
they have expertise), but also about aspects of user interface design, graphics, corporate

COMBINATIONS

REDUCE HYPERLINKS

ADVANTAGES
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identity, navigation, complex authoring tools, and details of HTML (where they have no
expertise). In other words, it would be impractical, and consequently users would have to
ask a dedicated Webmaster to insert their information for them. This, in turn, would
adversely affect the quality and timeliness of the information inserted.

· With the presentation (including layout and navigation) defined by an administrator in
advance, it is consistent throughout the site. This not only ensures that all pages conform to
a certain layout (including corporate identity), but it also means that users can rely on a
consistent user interface (including navigation).

· Since the layout is not defined directly in the documents, it can easily be changed
afterwards without having to touch the documents themselves. This means that one can
immediately start with a prototype system, have users insert information, and worry about
the details of layout later.

· You can also customize different interfaces to the very same information for different user
communities (e.g., employees in the intranet vs. partners and customers in an extranet) or
expertise (e.g., browse-only, authoring, administration). Users can even choose and
configure their favorite interface at runtime (personalized interface).

More information about customizing the user interface can be found in the Hyperwave
Programmer’s Guide.

1.2� METADATA AND SEARCHING

1.2.1� DOCUMENTS, OBJECTS, ATTRIBUTES

Unlike many other Web-based systems, Hyperwave Information Server stores its documents not
just as plain files in a file system. Rather, it keeps them in an object-oriented repository (a kind of
database), together with other information objects (e.g., structural elements). These objects carry
metadata, i.e. attribute names and values. Needless to say, documents can be of any type.

While the list of attributes is extensible, some attributes have meaning to Hyperwave Information
Server. We may classify attributes into the following groups:

· User-defined attributes: The user in this case is the application developer, who may define
any number of attributes that should be attached to documents (or some documents) and
other objects. Within this group we may distinguish between:

· Indexed attributes, which can be searched for. This property has to be specified by the
system administrator.

· Non-indexed attributes, which cannot be searched for and have only informational
purpose.

· System-defined attributes: These attributes have meaning to the system, i.e. they are set
and/or interpreted by the system itself. The system also defines which of them need to be
indexed. We can further refine this group to:

· Read-only attributes, the values of which are set and maintained by the system and
cannot be changed by the user. Examples include the attributes TimeCreated,
TimeModified, and Size (in Bytes).

· Read-Write attributes, which can be set by the user (see Figure 5) and are only
interpreted by the system. Examples include Name (the URL of the object), Title (is

TYPES OF ATTRIBUTES
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displayed in collection listings and other places), Rights (defines access permissions),
and TimeExpire (a date after which the object becomes invisible).

Figure 5: "Edit attributes" dialog

The ability to define arbitrary attributes (metadata) for all kinds of objects prepares Hyperwave
Information Server for many applications, which would otherwise require the functionality of a
relational database.

A typical example, found in almost any intranet, is an employee directory. Every employee is
represented by an object with user-defined attributes such as Lastname, Firstname, Middlename,
Phone, Fax, Email, and Department, which are all indexed and thus searchable. The objects are
inserted into a collection with a modified search dialog, which lets you search for boolean
combinations of the above attributes. In a better implementation, we would not insert all
employees into one large collection, but have a collection hierarchy representing the company
hierarchy, with one collection for every department. Thus users could also browse instead of
search, if they so prefer. The employee objects could also be documents or MultiClusters, so that
we can offer additional information (e.g., pictures, work descriptions) per employee.

1.2.2� SEARCH CAPABILITIES

As already discussed, Hyperwave Information Server allows searches in (indexed) attributes and
Boolean combinations, for example:

· "Images with ’X’ in their Title or Keyword attribute"

EXAMPLE

ATTRIBUTES
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· "Any objects (collections, documents, hyperlinks) created by user Y in the last week"

In addition, you can search in the full text of documents7, using the following advanced features:

· Thesaurus (search for synonyms)

· Stemming (find expression in singular, plural or declined)

· Phonetic search (find words with similar pronunciation)

· Case sensitive/insensitive

· Proximity search (all words specified must appear in the same paragraph, or sentence, or
immediately after each other, or within 5 words of each other).

Figure 6: Extended Search Dialog

Figure 6 shows the "extended search" dialog of the default user interface that comes with
Hyperwave Information Server. Needless to say, it is completely configurable. An important
feature shown in Figure 6 is the ability to specify the search scope. Unlike many other search
engines, which let you search the whole information space only, Hyperwave Information Server
lets you restrict the scope to a certain subset of the collection hierarchy. The scope can be only one
collection, a set of collections, the whole server, or even a set of collections residing on different
Hyperwave Information Servers. This is an extremely useful feature, since it lets you (the user, not

�����������������������������������������������������������������������

7 Hyperwave Information Server integrates Verity’s Search97 product, which is able to index more than 200 document
formats.

FULL TEXT

SCOPE
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the information provider!) narrow down the search to a specific subset of the information you are
currently interested in, and reduces the number of unwanted hits significantly.

Figure 7: Search results

Searching is tightly integrated with navigation, so that when you navigate the collection hierarchy
and press search at one point, the scope is by default set to the collection you are currently visiting.
Conversely, when you have selected a search hit, you can explore the "vicinity" of the selected
object in the collection hierarchy, and perhaps find more useful information related to the subject
you have been looking for. Search hits are shown as a ranked list (see Figure 7), the format of
which (e.g., what object attributes are displayed) is again completely customizable.

1.2.3� STORED QUERIES AND NOTIFICATIONS

The “Search Results” window (Figure 7) has a button labeled "save query" at the bottom, which
lets you store the query you just made as an object in the repository (see Figure 8), and re-evaluate
it again and again. This query object is displayed as an object in the collection hierarchy. When you
select such an object, it behaves like a collection. However, the members of the collection are not
statically linked to it, but rather are generated on the fly by evaluating the query.

This is a very powerful feature, as it allows new, dynamic views of existing material. Consider the
previous "calendar of events" example. It contains a – potentially quite large - single collection with
events. Let us assume I am a user interested only in events that deal with intranets. Assuming the
system administrator enabled that feature for me, I could create my personal calendar of intranet-

EXAMPLE
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related events by specifying a query that searches for documents containing "intranet" (and
perhaps also "extranet" and "knowledge management") in their title or full text, within the event
collection only. Then I would save this query in my home collection. Then, whenever I navigate to
this query object, I will get a list (or, if I make it a MultiCluster object, a combined document)
containing only the events relevant to intranets. Of course, I could also have a system
administrator set this up for me.

Stored Queries may not only be activated interactively by users, they can also be performed by the
system according to a schedule specified by the user. In this case, users may "subscribe" to the
query object and receive e-mail in either HTML or ASCII format with descriptions and URLs of
the objects found.

Figure 8: Query Object Wizard

For example, I could slightly modify the query specified in our previous example to only return
those events having to do with intranets, which have been created or updated within the last 24
hours. Then I would let the system evaluate the query daily (at a certain time), and send me the
result, if any, by e-mail. Then I can forget about the query object and relax; the Hyperwave
Information Server will automatically inform me of new events or changes in events related to
intranets.

Please note that in principle the notification functionality is similar to what has become known as
channels, push technology, or subscription services. An important difference, however, is that with
Hyperwave Information Server, users are no longer passive consumers of prepackaged
information channels. Rather, it is the users who are in the driver’s seat and perform their own
"information mining" according to their objectives, effectively creating their own channels.

NOTIFICATIONS

EXAMPLE
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1.3� LINK MANAGEMENT

Traditional Web-based systems keep link information directly within the source document, i.e. the
document the link emanates from. Since the link information is only available in the source
document, it is difficult to maintain the link consistency of (large) Web sites: when you are about
to delete a document and want to know what other documents refer to this document, you have to
look through all other documents for hyperlinks to this document. Obviously, this is prohibitively
expensive for an intranet site with tens of thousands of documents.

To avoid these problems with link consistency, the designers of Hyperwave Information Server
chose a radically different approach to link maintenance: hyperlinks are separated from documents
and stored as objects in their own right, in the same object repository as documents, collections
and the like. In the case of HTML pages, for example, this means that the hyperlink information is
extracted when the HTML page is inserted, stored in the repository, and dynamically merged back
into the document when it is served to the user.

Links are realized as one or two objects: a source anchor defines the region the link is emanating
from (e.g., a sequence of characters in a text or a region of an image). The source anchor points to
either

· a destination anchor, which is another region in the destination document, or

· to a whole document, or

· to a container object, i.e. a group of documents (multi-ended link).

What are the advantages of this additional complexity?

· Links are bidirectional. This means that it is possible to find the link source from the link
destination (this is a simple operation performed by the repository). Users can navigate to
the source from the destination, and the system can generate nice looking link maps like
the one shown in Figure 9, showing both incoming and outgoing links around a given
document.

Figure 9: Link Map

· The bidirectional links are used to guarantee link consistency in arbitrarily large sites. For
example, when a document is removed, links pointing to it are marked as invalid and are
not merged into the corresponding documents (in other words, they become invisible for

LINKS SEPARATED FROM
DOCUMENTS

ADVANTAGES
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ordinary users). When a document with the same name is inserted into the same collection,
the links are restored again. Similarly, when a document is moved or renamed, the links
follow. A server-server protocol even ensures this behavior across server boundaries.

· Source and destination anchors are objects, i.e. they have attributes such as title, author,
creation time, link type, etc. This means, for example, that it is possible to search for links
which were created by a given user during a given time range.

· In particular, links can be assigned individual access permissions, meaning that certain
links in a document can be defined to be visible and thus accessible only for certain users or
user groups. This is useful for presenting customized or personalized information, where
different users see different hyperlinks.

· Creating a source or destination anchor in a document requires no modification of the
document. This makes it possible to create hyperlinks in otherwise read-only documents,
which is, e.g., useful in the case of annotations: users can be given the right to create
annotations (which are basically hyperlinks with a certain link type) to documents, but
denied the right to make modifications to that document.

· Many document types are not prepared for storing links in their respective encodings (e.g.,
images), or explicitly allow external hyperlinks (such as XML). Hyperwave Information
Server is well prepared to manage hyperlinks in such document types.

1.4� CUSTOMIZED VIEWS

1.4.1� HIGHLY CONFIGURABLE USER INTERFACE

Hyperwave Information Server comes complete with a default user interface, as shown in Figure 5
to Figure 8. This interface offers the complete functionality available, including advanced
authoring and administrative functions.

However, in nearly all intranet installations of Hyperwave Information Server, the user interface is
customized to the needs of the customer. Typically, the graphics are changed to conform to the
customer’s corporate identity rules, and functionality is reduced for certain user groups. In some
occasions, new functionality is added. Fortunately, flexibility in the user interface is one of the key
features of Hyperwave Information Server.

The basis of the user interface is, of course, HTML and JavaScript. For newer browsers (Netscape
Communicator 4.x, Microsoft Internet Explorer 4.x), it also makes use of Dynamic HTML
(DHTML), Cascading Style Sheets (CSS), and JavaScript 1.2. The server automatically senses the
browser version, and sends the corresponding instructions to the client. The interface for older
browsers needs more images, and is slower.

Hyperwave Information Server dynamically assembles the HTML sent to the browser out of
predefined, customizable building blocks. This process is controlled by an HTML extension called
PLACE, which is a small macro language. Basically, PLACE macros are evaluated to HTML code.

In addition to the relatively simple PLACE language, Hyperwave Information Server also supports
server-side JavaScript (SSJS). Together with a JavaScript interface to the Hyperwave API, this
offers applications programmers a very high degree of flexibility in design of their applications.
The JavaScript code is precompiled and executed directly in the server, which yields high
performance. The Hyperwave API gives access to all functions of the server, thus making it
possible to extend the server with almost arbitrary functionality.

DYNAMIC HTML

PLACE

SERVER-SIDE JAVASCRIPT
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In addition, application programmers may of course make use of client-side application
development tools, such as (client-side) JavaScript, Java Applets, ActiveX controls, and the like.

Application programmers and system administrators can configure different interfaces to be sent
to different user groups or users acting in certain roles. A number of possibilities exist to
distinguish user groups:

· Hyperwave Information Server can be distributed to execute on a number of physical
computers in parallel. Most important, the Web interface can be separated from the
repository, and multiple Web interfaces can access the same repository. Consequently,
there may be multiple Web interfaces on different computers (or on the same computer,
but listening on different ports) with different user interfaces. This is useful in
intranet/extranet applications, where internal users connect to a different machine than
external users, and see the same information with different interfaces. The Web interface
for the external users will then reside outside a firewall, and only connect to the repository
through the firewall, while the internal Web interface will be inside the firewall.

· The interface can be designed to behave differently depending on users or user groups. For
example, anonymous users could be given a very simple interface. When they log in to the
server, the interface would become more functional. Members of the "system
administrators" user group would get the interface with the highest functionality, including
user administration functions.

· Users can also be distinguished by the IP address of the client (or proxy server) they are
connecting from. Connections from a certain group of IP addresses can be configured such
that they are automatically identified as some (low-privilege) user, which is distinguishable
from the completely anonymous users coming from other IP addresses. This is again useful
in intranet/extranet applications, where internal users can automatically (without having to
log on) be given higher privileges (e.g., read access for certain parts not visible for external
users), a different starting point for navigation, and a different user interface.

· Also, the very same user may act in different roles, or modes. Typically, the interface can be
kept rather simple and fast for browsing users. If a user switches to "edit mode", the
interface becomes more functional.

· Since such user modes are saved in client-side cookies, users can also to some extent
customize the interface to their preferences, and have them remembered between sessions.
For example, it is possible to select a certain interface language, preferred MIME Types and
quality, and select between different interface styles. Of course, the system administrator
determines the extent to which such personalizations are possible.

1.4.2� PERSONAL COLLECTIONS AND AGENTS

So far we have covered the mechanisms that application programmers and system administrators
use to customize the user interface. We will now talk about how users and information providers
can create customized views of the information space.

Information providers can create multiple views (hierarchies of structure elements) of the same
information. For example, a parts catalog could be structured both by the type of part and by its
geographical location. Users can be given the choice of navigating either way, depending on the
task at hand.

CLIENT-SIDE JAVASCRIPT,
JAVA APPLETS, ACTIVEX

 CUSTOMIZED USER
INTERFACE

MULTIPLE VIEWS
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Figure 10: Multiple views of the same information

For some applications it is useful to not allow users the choice, but rather force them to take a
specific path of navigation, depending on their user group. This can be controlled with appropriate
access permissions of the structural elements. Also, so-called "user templates" allow local
redefinition of the user interface for given objects (e.g., collections). This means that the default
user interface can be overridden when the user accesses a certain part of the information space.

Figure 11: Customized navigation with access rights on hyperlinks

A different way of customizing navigation paths is shown in Figure 11. Here, hyperlinks are
assigned different read access rights so that different users see different links in the documents, and
consequently follow different navigational paths.

Optionally, identified users can be assigned a home collection, where they can build their own view
of the information space, like a highly sophisticated bookmark list. They can create shortcuts to
frequently used information, structure them in collection hierarchies, and store personal
documents, annotations, and hyperlinks.

Users can also store query objects in their home collections. Stored queries behave like dynamically
calculated collections, which means users can create personal, dynamic views of existing
information. In addition, such personal views can act as agents and inform their creators by e-mail
when their contents change (see Figure 8). Please note that unlike "push" channels, where users are
more or less passive information consumers, with Hyperwave Information Server the users are in
control and can define their personal agents themselves.

HOME COLLECTION

PERSONAL AGENTS
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1.5� COLLABORATIVE AUTHORING

Hyperwave Information Server enables ordinary users to become intranet information providers.
No longer is the publishing process restricted to a limited set of Webmasters or publishers. This is
made possible because authors can focus on the content they want to provide, while the system
takes care of the details, such as navigation, consistency, user interface, and graphical layout. We
believe this is an important step necessary to make intranets work.

This section deals with the various methods of publishing information to a Hyperwave
Information Server.

1.5.1� AUTHORING CAPABILITIES

A standard Web browser is sufficient to perform all functions of Hyperwave Information Server,
including authoring and administrative functions. In particular, it is possible to insert individual
files into collections (i.e., upload them from the local file system; see Figure 12), create collections,
edit attributes, delete objects, and move objects around in the collection hierarchy. Small text
documents can be directly inserted and edited in an HTML form. Netscape’s "publish" function
(HTTP PUT) is also supported.

Figure 12: Uploading a file into a collection

These methods of inserting information into and manipulating information on the Hyperwave
Information Server require no additional client software (just a Web browser), and are platform-
independent (i.e., users can publish from Windows, UNIX, MacIntosh, or Network Computers).
In addition, more convenient methods of publishing information exist for client computers
running Windows95 or Windows NT. These methods are explained below.

Microsoft offers an API for publishing information to Web servers, called WEBPOST API. The
user sees this through Microsoft’s Web Publishing Wizard. This has been extended to include the
ability to publish to Hyperwave Information Servers, becoming the Hyperwave Publishing Wizard
(see Figure 13). The Wizard allows upload of multiple files or whole directory structures in one
step.

WEB BROWSER

PUBLISHING WIZARD
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Figure 13: Hyperwave Publishing Wizard

The Open Document Management API is a standard API for reading and storing documents
from/to document management systems. It is also supported by Hyperwave Information Server.
This means that ODMA-aware clients (e.g., Microsoft Word 97, Microsoft Powerpoint 97) can
directly access documents on the Hyperwave Information Server, bypassing the Web browser (see
Figure 14)

Figure 14: ODMA SaveAs dialog in Word 97

ODMA
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Under Windows 95 and Windows NT it is possible to extend the name space of the operating
system, i.e. to make objects look like files and directories in the Explorer. The so-called Hyperwave
Virtual Folders is such a name space extension, and behaves like a network file system. Users can
browse information on a Hyperwave Information Server as if it were a file system (see Figure 15),
use "drag and drop" interface to move files between Hyperwave Information Servers and other file
systems, edit attributes, etc.

Figure 15: Hyperwave Virtual Folders

1.5.2� DOCUMENT MANAGEMENT FUNCTIONS

Hyperwave Information Server also supports typical document management functions, which
enable cooperative editing in the information space. In particular, objects can be locked while they
are being edited. It is also possible to use version control on documents. In this case, the document
is checked in and each time a user wants to edit it, he or she must check it out. This creates an
experimental version and the document is locked. While authors can now edit and test the
experimental version, other users still see the latest committed version of the same document.
Only when the document is checked in again does this version become the current version for all
users. Of course it is possible to look at old versions and to revert to an old version.

Version control can be performed interactively using the Web browser, but also using the
Hyperwave Publishing Wizard, the ODMA interface, or the Windows Name Space Extension. In
addition, there are corresponding API functions for version control, so that versions can be
manipulated programmatically.

1.5.3� GROUPWARE FUNCTIONS

Users can annotate (i.e. make a comment on) documents and collections. These comments are
stored as documents, and thus they can, in turn, be annotated again. This means that any
document or collection can be the starting point of an asynchronous electronic discussion.

WINDOWS NAME SPACE
EXTENSION

VERSION CONTROL

ANNOTATIONS
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Annotations can be made public (readable by all users), private (readable only by the author), or
group annotations (readable by a defined discussion group). Annotations may be addressed to
individual locations in the document, or the whole document.

In addition, careful setting of stored queries with notifications can inform members of the
discussion group of new annotations, thus integrating Hyperwave’s annotation functions with e-
mail.

1.6� SECURITY

Hyperwave Information Server enables anybody in an organization to publish information in the
organization’s intranet. Naturally, this requires a strong security model suitable for collaborative
authoring, which protects the work of one user from other users.

1.6.1� FINE-GRAINED ACCESS CONTROL

Every object (document, container, hyperlink, script) stored in the Hyperwave Information Server
has associated access rights. Access rights specify who is allowed to

· read

· write (modify)

· unlink (delete)

the object in question. The access rights are reflected in the Rights attribute of an object. For
example, having write permission to a document means one is allowed to modify the document,
whereas having write permission to a collection means one is allowed to insert or remove members
from that collection.

In order to keep things simple, reasonable defaults have been specified. By default (i.e. when no
other access permissions are specified), everybody is granted read access, and only the creator of
the object has write access. When no unlink permission is specified, those that have write
permission also have unlink permission. When a new document is inserted into a collection, the
document inherits its access rights from the collection.

The Rights Wizard allows users to set permissions for individual objects without having to
remember the syntax of the Rights attribute or the valid user and group names (see Figure 16).

NOTIFICATIONS

DEFAULTS

RIGHTS WIZARD
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Figure 16: Rights Wizard

1.6.2� USER AND GROUP MANAGEMENT

Hyperwave Information Server supports a hierarchical scheme of users and user groups. A user
(represented by an object in the repository) can be a member of one or more groups (also objects),
which in turn can be members of one or more other groups.

As always, administration of users and user groups is possible using a Web browser. The system
administrator(s) can create new users and groups, modify existing users and groups, delete them,
and assign users and groups to groups. See the Hyperwave Administrator’s Guide for details.

MANAGEMENT USING A
WEB BROWSER
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Figure 17: User and Group administration

1.6.3� DIRECTORY SERVICES

Large organization will typically have a directory of users already in place, and will not want to
duplicate the users and groups already stored in this directory into the Hyperwave Information
Server repository.

Therefore, Hyperwave Information Server supports an External Authentication Interface, a
documented software interface where customers and partners can connect their existing directory
service. When a user logs on, the external directory service is asked whether username and
password are correct, and what groups the user belongs to, instead of looking it up in the internal
user directory.

In order to reduce the customization effort, Hyperwave Information Server comes with three
standard interfaces:

· LDAP (Lightweight Directory Access Protocol) compliant directory servers.

· Windows NT user directory

· NIS (Network Information Services; a.k.a. Sun YP)

1.6.4� ENCRYPTION

Hyperwave Information Server is based on open standards, and uses HTTP for transfer of data
between the Web browser and the server. Unfortunately, HTTP foresees sending all information in
its header (including user information) in (almost) clear text. While this may be no problem in an

EXTERNAL
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intranet environment, where the network is usually trusted, it is definitely a problem in extranet
applications.

Hyperwave Information Server optionally uses version 2 of the Secure Socket Layer (SSL) protocol
to encrypt all information (including documents) sent to the browser. Since the software is made
outside the U.S., it is not subject to U.S. export regulations, and uses full 128-bit symmetric keys
for the encryption (provided that the browser allows it).

It is in principle possible to store documents in encrypted form on the server, so that nobody – not
even the system administrator – can read them. In this case, full text search is of course not
possible, and the client needs to configure a helper application to decode the documents before
displaying them.

SSL
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2 GETTING STARTED WITH
HYPERWAVE INFORMATION
SERVER

2.1� VIEWING INFORMATION IN HYPERWAVE

Viewing information on a Hyperwave Information Server is as simple as viewing information on
any multimedia server. Figure 18 shows a typical Hyperwave page. Hyperwave, however, offers you
more ways to navigate through the information on the server than just following the reference
links that happen to be available on a page.

Figure 18: A typical Hyperwave page

Chapter 1 of this manual describes Hyperwave’s functions and features. There you can read about
collections, which organize information on the server, and clusters, which control how a group of
documents is presented and in what language. Because every collection and document in
Hyperwave is a member of a collection, it is possible to navigate up or down in the collection

This chapter shows how you can take advantage of Hyperwave’s rich functionality
using Internet clients. You will find explanations of how to upload documents to the
server, delete them, run a search, create links, etc. The Hyperwave Publishing
Wizard, a tool for publishing multiple documents to the Web, is also described.

INFORMATION
STRUCTURING
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hierarchy and access all documents on the server without the explicit use of hyperlinks. Figure 19
shows how collections automatically display their members as a list of links. By clicking on a
collection in this listing, you can, in turn, display its contents as a list of links.

Hyperwave displays certain information about each object in a collection listing in the default
interface. A “new” or “updated” icon is shown for 24 hours next to any items which have been
newly uploaded or edited. If you are in authoring mode, the size (of documents) or the number of
subdocuments each object contains (for collections), as well as the name of the owner, is displayed.

Figure 19: A collection listing

Clicking on an attributes icon ( ) in a collection listing lets you view the attributes of the
corresponding object, with the option to edit them if you have the proper access rights. Many
attributes, such as TimeCreated and TimeModified are maintained by the server. Others, such as
Title, Owner, Rights (the access rights assigned to an object), and PresentationHints (an
attribute which lets you override the presentation of collections as lists) can be changed. Most
editable attributes control various aspects of the presentation of objects on the server. Others, such
as Keyword, let you associate words with an object to make searching for it easier. See page 74 for
a complete listing of all available attribute types with explanations of their functions.

To take full advantage of the functionality of the Hyperwave interface, a JavaScript 1.1 capable
browser is required. The browsers listed below are recommended for use with Hyperwave
Information server 4.x.

· Windows 95 or Windows NT: Netscape Communicator/Navigator 4.x, Microsoft Internet
Explorer 4.x

· UNIX: Netscape Navigator/Communicator 4.x

HINTS ABOUT UPDATED
INFORMATION, DOCUMENT

SIZE, ETC.

OBJECT ATTRIBUTES

RECOMMENDED
BROWSERS
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Browsers with a few restrictions in functionality with respect to text selection while creating links
and name suggestion when uploading files are

· Windows 95 or Windows NT: Netscape Navigator 3.x, Netscape Navigator Gold 3.x,
Microsoft Internet Explorer 3.x with JavaScript 1.1 support

· UNIX: Netscape Navigator 3.x, Netscape Navigator Gold 3.x

Other browsers may not display JavaScript properly.

Hyperwave Information Server version 4.x has a new, menu-driven interface. This interface is
automatically used by the server if you are using Netscape Navigator/Communicator 4.x, or
Microsoft Internet Explorer 4.x. If you are using an older version of one of these browsers, the
server uses the user interface from version 2.6 of Hyperwave.

The descriptions of Hyperwave Information Server functions found in this guide are based on the
default user interfaces of Hyperwave Information Server 4.1 and 2.6. Keep in mind that the
Hyperwave interface is very flexible and can be arbitrarily changed by system administrators (see
the Hyperwave Programmer’s Guide) to fit the needs of the user. Thus the interface on the server
you are using may be different from the interface described here.

2.2� “VIEW” MODE

All guest users, as well as identified users who are not in authoring mode, are in view mode when
browsing a Hyperwave Information Server. This mode allows users to browse information on the
server, run a search, change user interface preferences and log in to the server. If you are an
identified user, you have the additional option of switching to authoring mode. There are no
pulldown menus in this mode; all functions are accessed directly from the menu bar.

There are five buttons on the menu bar in view mode:

· Search

· Home

· Preferences

· Login

· Help

An additional button appears for identified users:

· Authoring

The functions available in view mode are described below.

Search: This button gives you access to the simple and extended search forms in a separate
window. These forms allow you to find documents on any part of the server you have read access
to.

Home: Clicking on this button takes you to the default server entry page if you are a guest user,
and to your personal home collection if you have one and are identified.

Preferences: This button displays a window that lets you select various user interface preferences,
e.g. interface language, document quality, sort order of collection listings, interface appearance,
etc.

Login: This button displays a window where you can enter your Hyperwave user name and
password.

Help: This button displays the online help index.

Authoring: This button appears only when the user is identified. This button switches from view
mode to authoring mode, allowing the user access to the full publishing and modification options
that the server offers, in addition to all the functions available in view mode.

HYPERWAVE INTERFACE
VERSION 4.X

FLEXIBILITY IN THE
INTERFACE

OVERVIEW OF FUNCTIONS

SHORT DESCRIPTION OF
FUNCTIONS
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In the sections that follow, the options for view mode are explained in greater detail.

2.2.1� SEARCH

Hyperwave Information Server has integrated search facilities, including a choice between its
native fulltext engine and the commercial fulltext indexer Verity. This section describes the default
forms for simple and extended search when using Hyperwave with version 4.x browsers as well as
those when using older browsers. The forms are different depending on if Verity or the native
search engine is being used. This can only be configured by the server administrator. Note that the
server administrator can modify the search interfaces to let you search in any indexed or non-
indexed attribute.

Hyperwave Information Server lets you search the content of text documents in most common
formats, such as Microsoft Word, Microsoft Excel, HTML, RTF, and Lotus 1-2-3. This option is a
powerful aid in getting the information you need. For example, you may be working for a big
company with a large server that contains information that is useful to you on the job. You can
think of this large information repository as being analogous to a library. As in any library, you can
search by document title, but with Hyperwave you can also search on content. This is like being
able to search every page in every book in a library for a word or combination of words in a single
step. The default Hyperwave interface allows you to search in fulltext, as well as by certain
attributes. These attributes include Author (the name of the person who uploaded the object),
Name (the URL of the object), and TimeModified (the date and time a document was last
modified). Searching by date of last modification allows you to limit your search to find only the
most up-to-date documents.

2.2.1.1� THE VERITY SEARCH ENGINE
Hyperwave comes with two different fulltext search engines, the commercial fulltext indexer Verity
and the native search engine. The system administrator can configure the server to use the search
engine of choice. The search interface consists of a simple search form and an extended search
form. Note that the appearance of the extended search form varies depending on which search
engine is being used. See page 31 for a description of the interface when using the native search
engine. The Verity search engine is used by default.

To use the simple search form for version 4.x browsers, do the following:

1. Click on Search on the toolbar.

2. In the window that appears, enter a search term or terms in the Search for field. Multiple
terms are combined with “OR”, i.e. at least one of the terms will be present in every
document found.

3. Select what you want to search in under in document. You can search in the attributes of
objects or the content of text documents. At least one of these boxes must be checked. See
page 74 for a list of attribute types with explanations.

4. Select the Search scope using the radio buttons. Your options are to search the entire
server, restrict the search to the collection you were browsing when the search form was
accessed, or search the server pool (if the server is a member of one). Your system
administrator may add further options.

5. Decide how to sort the results using the list box. You can sort them according to
importance (how well they match the search criteria), date created, date last modified,
title or owner.

6. Click on the “OK” button.

To use the simple search form for older browsers (see Figure 20), do the following:

1. Click on the “SEARCH” icon in the Hyperwave toolbar.

2. Click on the “Simple Search” tab.

DETAILED DESCRIPTION OF
ITEMS

FULLTEXT AND ATTRIBUTE
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THE SIMPLE SEARCH FORM
WITH VERSION 4.X

BROWSERS
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3. Enter a search term or terms in the Search for field. The terms are combined with “OR”,
i.e. at least one of the terms will be present in every document found.

4. Select what you want to search in under in document. You can search in the attributes of
objects or the content of text documents. At least one of these boxes must be checked. See
page 74 for a list of attribute types with explanations.

5. Select the Search scope using the radio buttons. These options allow you by default to
search the entire server, restrict the search to the collection you were browsing when the
search form was accessed, or search the server pool if the server is a member of one. Your
system administrator may add further options.

6. Decide how to sort the results using the list box. You can sort them according to
importance (how well they match the search criteria), date created, date last modified,
title or owner.

7. Click on the “Search” button.

Note: Remember to log in to the server before making your search if you are searching for information
which is not available to anonymous users.

Figure 20: The simple search form

The extended search form (see Figure 21) lets you take advantage of Verity’s advanced features.
Verity offers fulltext search with several options, including

· a thesaurus, to find documents that contain words that have the same meaning as your
search term

· a function that finds grammatical variations of the search term (for example, if you enter
the term “compute” you will also find any documents that contain the words
“computing” or  “computers”)

· a function that finds words that sound like your search term

· case sensitive search

· a function for associating one or more search terms, e.g. all search terms should be found
in the same document, same paragraph, same sentence, etc.

THE EXTENDED SEARCH
FORM
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Figure 21: The extended search form when using the Verity search engine

The extended search form also offers various options for finding documents by searching in titles
or keywords, date the document was last modified, or author. Lastly, the results can be filtered by
MIME type and language.

Extended search with Verity is done as follows with version 4.x browsers:

1. Click on Search in the toolbar. The “Search” dialog box appears. Click on the “Extended
Search” button in this dialog box.

2. Enter one or more words in the “Search For” text box.

3. Switch content search on or off by selecting or deselecting the “In Contents” check box.
When content search is turned on, the “thesaurus”, “variations”, “sounds like” and “case-
sensitive” checkboxes can also be selected. Use the listbox to specify how you want the
search terms to be associated in the documents found, e.g. all words in same document
(AND), all words in same sentence, etc.

4. Select any or all of the attribute types (Title, Keyword, etc.) you want to search in using
the checkboxes. Use the listbox to specify whether you want all (AND) or at least one
(OR) of your search terms to be present in the attributes of the objects found.

5. Optionally enter a Hyperwave user name in the “Owner” field if you want to find objects
created by a particular user.

6. Enter preferences for date created and date modified of the objects found. The date can be
entered in the form MM/DD/YYYY, e.g. “03/30/98” or relatively to the current date. A
relative date can be specified in terms of minutes, hours or days. You can, for example,

EXTENDED SEARCH WITH
VERSION 4.X BROWSERS
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enter “–3days” or “–3d” to mean “the date which is three days before today”. By entering
“-3d” in the “after” field of the search form, you can easily find all documents which were
uploaded to the server in the last three days. It is also possible to enter e.g., “-2minutes” to
find documents inserted in the last two minutes, or “–1hour” to find documents inserted
in the last hour.

7. Select a MIME type from the listbox if you want only a particular document type in your
search results.

8. Select the search language. Default choices are German and English.

9. If you don’t want the documents found to contain a particular word, enter the word in
the appropriate field.

10. Select the search scope. This tells Hyperwave which part of the server it should search on.
You have the choice between searching the collection you were browsing when you
accessed the search form, searching the entire server, or searching the server pool if the
server is a member of one.

11. Select how you want to sort the results using the listbox.

12. Click on the “OK” button.

Extended search with Verity is done as follows with version 2.6:

1. Click on the “SEARCH” icon in the Hyperwave toolbar.

2. Click on the “Extended Search” tab.

3. Follow instructions for Extended Search version 4.1 starting with item 3.

Note: Remember to log in to the server before making your search if you are searching for information
which is not available to anonymous users.

2.2.1.2� THE NATIVE SEARCH ENGINE
Hyperwave offers two different search forms: a simple search form, where only a few preferences
for the search can be entered, and an extended search form, where additional restrictions, such as
author and time modified can be specified. The search forms vary depending on if the Verity or
native fulltext engine is being used. See page 28 for a description of the Verity search interface.

Simple search is the same whether using the Verity or the native search engine. See page 28.

The extended search form offers all the search functionality of the simple search form and more.
Here you can additionally search by author, language, time created, time modified, etc. It is used as
follows in 4.x versions:

1. Click on Search in the toolbar. The “Search” window appears. Click on the “Extended
Search” button in this window.

2. Enter one or more words in the “Search For” field.

3. Turn content search on or off by selecting or deselecting the “Full Text Search” button.
Use the listbox to specify whether you want all (AND) or at least one (OR) of your search
terms to be present in the content of the objects found.

4. Select any or all of the attribute types (Title, Keyword, etc.) you want to search in using
the checkboxes. Use the listbox to specify whether you want all (AND) or at least one
(OR) of your search terms to be present in the attributes of the objects found.

5. Optionally enter a Hyperwave user name in the “Owner” field if you want to find objects
created by a particular user.

6. Enter preferences for date created and date modified of the objects found. The date can be
entered in the form YY/MM/DD, e.g. “98/03/30” or relatively to the current date. A
relative date can be specified in terms of minutes, hours or days. You can, for example,
enter “–3days” or “–3d” to mean “the date which is three days before today”. By entering
“-3d” in the “after” field of the search form, you can easily find all documents which were
uploaded to the server in the last three days. It is also possible to enter e.g., “-2minutes” to
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find documents inserted in the last two minutes, or “–1hour” to find documents inserted
in the last hour.

7. Select a MIME type from the listbox if you want only a particular document type in your
search results.

8. Select the search language. Default choices are German and English.

9. If you don’t want the documents found to contain a particular word, enter the word in
the appropriate field.

10. Select the search scope. This tells Hyperwave which part of the server it should search on.
You have the choice between searching the collection you were browsing when you
accessed the search form, searching the entire server, or searching the server pool if the
server is a member of one.

11. Select how you want to sort the results using the listbox.

12. Click on the “OK” button.

Extended search with the native search engine is done as follows:

1. Click on the “SEARCH” icon in the Hyperwave toolbar.

2. Click on the “Extended Search” tab.

3. Follow the instructions for Extended Search version 4.1 starting with item 3.

Note: Remember to log in to the server before making your search if you are searching for information
which is not available to anonymous users.

2.2.1.3� REFINING QUERIES AND CREATING QUERY OBJECTS
After your search is complete, the results are displayed as a list of titles linked to the actual
documents. Each item in the list includes an icon representing document type, the relevance of the
document to the search in percent, an icon which tells whether the search term was found in
content or attributes or both and a description (see Figure 22).

THE EXTENDED SEARCH
FORM WITH OLDER

BROWSERS
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Figure 22: The Search Results page

After you have run a search, you can click on the “Refine Query” button at the bottom of the
search results page to change the query you entered for that search and run a new search.

REFINING THE QUERY
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Figure 23: The Save Query window

Hyperwave allows you to create query objects, which are queries that are stored on the server and
can be executed as the user wishes. If an evaluation schedule has been entered for the query object,
the query is run periodically, and sends the results to a specified email address. In this case, it is
called a subscription.

1. Log in to the server and run a search using either the simple or extended search form. The
results of the search will appear on the search results page along with a “Save Query”
button (see Figure 22).

2. Click on the “Save Query” button. The “Save Query” window (see Figure 23) appears.

3. Specify a Title for the query object. Select the appropriate language from the list. This title
will appear in the collection listing.

4. Specify a Name for the query object.

5. Specify the Name attribute of the collection you want to insert the query object into.

6. Enter an optional description for the query object.

7. Specify the evaluation schedule for the query object. Use the checkboxes to select the days
of the week, or the listbox to choose the dates in the month on which you want the query
to be automatically executed.

8. Specify the interval in minutes you want the query to be run using the listbox, and specify
the times when you want the automatic searches to start and end.

QUERY OBJECTS

CREATING QUERY
OBJECTS/SUBSCRIPTIONS

WITH VERSION 4.X
BROWSERS
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9. Specify up to two email addresses where the results should be sent, as well as the format
you want the results sent in.

10. Click on the “OK” button. The query, as you originally entered it in the search form, will
be saved as a query object.

1. Log in to the server and run a search using either the simple or extended search form. The
results of the search will appear on the search results page along with a “Save Query”
button (see Figure 22).

2. Click on the “Save Query” button. The Query Object Wizard (see Figure 23) appears.

3. Specify the Name attribute of the collection you want to insert the query object into, a
title for the query object and a Name attribute for the query object.

4. Specify the days you want the query to be run. It is possible to select any or all days of the
week using the checkboxes, or any or all days of the month using the listbox.

5. Specify the interval in minutes you want the query to be run using the listbox, and specify
the times when you want the automatic searches to start and end.

6. Specify one or more email addresses that you want to have the results sent to, as well as
the format you want the results sent in.

7. Click on the “Create Query Object” button. The query, as you originally entered it in the
search form, will be saved as a query object.

When you create a query object, a corresponding item appears in the collection you specified when
creating the query object. This object looks like a pair of binoculars on a folder in the collection
listing (see Figure 24). Though the query object may have a schedule by which it is automatically
activated, it is also possible to click on it to activate it at any time. If you do this, the search results
are inserted dynamically into the query object on the server. Note that it is only possible to activate
the query by hand when not in edit mode.

CREATING QUERY
OBJECTS/SUBSCRIPTIONS

WITH OLDER BROWSERS

ACTIVATING THE QUERY
OBJECT MANUALLY
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Figure 24: Query Objects

It is possible to change the schedule which specifies when the query object should be automatically
executed. To do this, you must access the attributes of the query object and change the
HW_Schedule attribute. This is done as follows:

1. Log in to the server by clicking on Login.

2. Click on Authoring to switch to authoring mode.

3. Navigate to the query object (query objects are shown in collection listings with a
binocular icon as seen in Figure 24) and click on the “i” icon next to it.

4. Edit the HW_Schedule attribute, which specifies when and how often the query object is
evaluated. See below for syntax.

5. Click on the “OK” button.

The syntax for HW_Schedule is as follows:

Format: <day>; <starttime>, <stoptime>, <interval>;

<day> may be mo, tu, we, th, fr, sa or su (for the days of the week) or a number from 1 to 31 (for
the days of the month). <starttime> and <stoptime> give the beginning and ending time of
evaluation for the selected days. Note that if <stoptime> is left out, the query is carried out only
once for each specified day at <starttime>. <interval> is the interval in minutes that the query is
executed between <starttime> and <stoptime>.

To get a notification mail every Tuesday and Friday every 15 minutes between 8am and 5pm, you
would enter tu;08:00,17:00,15;fr;08:00,17:00,15.

Note: For subscriptions to work in Hyperwave, the server has to be configured to be able to run them.
If the subscription feature is not working, contact your server administrator.

CHANGING THE QUERY
SCHEDULE

EXAMPLE QUERY
SCHEDULE
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2.2.2� HOME

Clicking on “Home” in the tool bar brings you to the default home collection of the server if you
are not identified, and to your personal home collection if you are.

2.2.3� PREFERENCES

Clicking on “Preferences” in the tool bar makes the “Preferences” window appear (see Figure 25),
which allows you to change various aspects of the user interface:

· Language: Select your preferred language from the list. The user interface will be displayed
in this language (currently German and English are available) and documents will be
retrieved in the preferred language if available.

· Quality: Select a quality level from the list. If a document is available in different qualities,
the quality which best matches the user’s preference is sent. This setting is useful e.g. when
you have a slow network connection and would prefer to have lower quality but faster
transmission of documents.

· Sort Order: Select the sort order for collection listings from the available options.

· Sequence #, Title: This sorts first by sequence number, then by title.

· Creation Date: This sorts according to the time the object was created on the server.

· Author: This sorts alphabetically by the name of the user who created the object on the
server.

· View as: Select the preferred appearance for the collection structure.

· Listing: Only the contents of the collection you are currently browsing are displayed.

· Partial Tree: The contents of the collection you are currently browsing are displayed in
the context of a partial tree, i.e. only the succession of parents of the collection are
shown.

· Tree: When you open a collection, it is displayed in the context of the collection
hierarchy.

· Interface: Select the interface appearance from various options on the list.

· Interface Options: These options affect the appearance of the collection listing.

· Auto Scroll Tree: If this option is activated, the browser scrolls automatically to the
current collection.

· Show Subdocs: Switch this option on to display the number of subdocuments (i.e. the
total number of documents contained directly in the collection plus all documents
contained recursively in its child collections) next to each collection.

PREFERENCES WITH
VERSION 4.X BROWSERS
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Figure 25: The Preferences dialog

The Hyperwave interface that is used with older browsers allows users to change their language
and document quality.

1. Click on the “PREFERENCES” icon to make a form appear where you can set language
and document quality.

2. Make your selections in the listboxes and click on the “Apply Preferences” button.

The Hyperwave interface that is used with older browsers allows identified users to change their
passwords.

1. Log in to the server.

2. Click on the “PREFERENCES” icon then click on the “Change Password” tab.

3. Enter the old password, the new password and verify the new password. Click on the
“Change Password” button.

2.2.4� LOGIN

2.2.4.1� LOGGING IN
Logging in  will allow you access to restricted information and allow you to edit the contents of the
server if you have appropriate access rights.

With 4.x browsers, login is as follows:

1. Click on Login.

2. In the window that appears enter your user name and password and click on “OK”.

With older browsers, login is as follows:

1. Click on the “LOGIN” icon in the toolbar.

2. In the window that appears enter your user name and password and click on “OK”.

PREFERENCES WITH OLDER
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LOGIN WITH VERSION 4.X
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2.2.4.2� LOGGING OUT
Users who have logged in to the Hyperwave Information Server can log out again if they like.

1. Click on Login.

2. In the window that appears, enter “anonymous” as user name and no password.

1. Click on the “LOGIN” icon in the toolbar.

2. In the window that appears, enter “anonymous” as user name and no password.

2.2.5� HELP

The “Help” menu contains two items.

· Contents: Brings you to the Hyperwave help index.

· Hyperwave Home Page: Brings you to the Hyperwave WWW server.

2.3� AUTHORING MODE

For identified users, the item “Authoring” appears on the tool bar. Clicking on this item allows
access to Hyperwave’s authoring, modification and administration functions.

Seven menus appear when in authoring mode.

Site: This menu contains items relating to the server site, e.g. Search, Home, Preferences, etc.

Publish: The Publish menu contains items which are used for uploading collections and
documents to the server.

Modify: The Modify menu contains items for manipulating items on the server, e.g. for editing
text, inserting hyperlinks, deleting and moving objects, etc.

View: The View menu gives you access to object attributes, the link map, object locking and
version control.

Admin: This menu contains items necessary for administrating users and groups.

Login: Selecting this item causes the login window to appear (see page 38).

Help: This menu gives you access to help on Hyperwave functions (see page 39).

In the sections that follow, the options for authoring mode are explained in greater detail.

2.3.1� THE “SITE” MENU

The Site menu contains the items:

Search: See page 28.

Site Home: This item brings the user to the default home collection of the server.

User Home: This item brings the user to his or her personal home collection.

Server Pool: This item brings you directly to the server pool that your server is a member of (if a
server pool has been set up).

LOGGING OUT WITH
VERSION 4.X BROWSERS

LOGGING OUT WITH OLDER
BROWSERS

DETAILED DESCRIPTION OF
FUNCTIONS
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Change Password: Selecting this item causes a window to appear where you can change you
Hyperwave password. See below

Preferences: See page 37.

2.3.1.1� CHANGE PASSWORD
All users with an account on the Hyperwave Information Server can change their password.

1. Log in to the server by clicking on Login.

2. Click on Authoring to switch to authoring mode.

3. Select Site→Change Password. The “Change Password” window appears. Type in your
old password and your new password in the corresponding fields. Type in your new
password a second time in the “Verify New Password” field.

4. Click on the “OK” button.

2.3.2� THE “ADMIN” MENU

If you are a member of the group “system”, you can access certain information about the server
and administrate users and groups. The Admin menu contains the following items:

· Users

· Groups

· Assign Users and Groups

· Server Status

· Who is Online

The “Server Status” function lets you see the server name, up time, total amount of data retrieved
in megabytes, etc.

1. Log in to the server as a “system” user.

2. Click on the item Authoring on the toolbar.

3. Select Admin→Server Status.

The “Who is online” function shows you a list of users currently logged in to the server, including
user name, the host the user is connecting to the server from, their idle time, etc.

1. Log in to the server as a “system” user.

2. Click on the item Authoring on the toolbar.

3. Select Admin→Who is online.

See the Hyperwave Administrator’s Guide for information on managing users and groups in
Hyperwave.

2.3.3� THE “LOGIN” MENU

See page 38.
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2.3.4� THE “PUBLISH” MENU

This menu lets you access all functions for inserting new objects into the server, e.g. collections,
clusters, files, annotations, remote documents, etc. You can use these functions as long as you have
appropriate access rights for the collections you want to insert objects into.

The Publish menu contains the following items:

· File: Files of any type can be uploaded.

· Collection: A collection is a container used for holding other collections and documents.

· Cluster: Clusters allow you to combine multiple documents as desired.

· Sequence: This is a collection type which automatically links the items contained in it
sequentially.

· HTML: You can type in and upload an HTML text (to upload an HTML file, use the item
File).

· Text: You can type in and upload a plain text (to upload a text file, use the item File).

· Note: Formerly called “annotation”, this item allows you to make a comment on an object
on the server.

· Remote Document: A Remote Document is a link to a document on another server.

· CGI: This item allows you to create CGI objects.

The mechanism for inserting the above document types is explained in greater detail below.

2.3.4.1� INSERTING FILES
Files are inserted as follows:

1. Log in to the server by clicking on Login.

2. Click on Authoring to switch to authoring mode.

3. Navigate to the collection you want to insert the file into. Select Publish→File. The
“Upload File” window appears (see Figure 26). Keep in mind that you must have the
appropriate access to the collection where you want to insert the file.

4. Enter a Title for the document and select a language from the menu. If you leave the
Title field blank, the title used is the file name without the extension, unless the file is of
type HTML, in which case the title is parsed from the HTML file.

5. Enter a description if desired.

6. A Name (unique identifier for the object being inserted) is optional. If you are using
JavaScript and did not enter a name, a name, consisting of the name of the parent
collection and the file name separated by a slash (unless the file is an HTML file, in which
case the file name without the extension is used) will automatically appear in the Name

field after you press the “OK” button. Thus, if the file hyperwave.gif is inserted into
a collection with the name “graphics”, the suggested name is “graphics/hyperwave.gif”.

7. Click on “More” to enter additional attributes. The MimeType attribute is explained
below; all other attribute types are explained on page 74. The Custom Attribute field
allows you to enter an attribute with the name and value of your choice.

8. Enter the full path for the file you want to insert or use the file browser to select a file.

9. Click on the “OK” button.
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Figure 26: Uploading a file

Files are inserted as follows using earlier versions of the Hyperwave interface:

1. Log in, switch to edit mode by clicking on the “EDIT” icon, and click on the “new

document” icon ( ) to access the “new document” form.

2. Select the “File” tab.

3. Enter the Name or GOid of the collection you want to insert the file into. Default is the
collection you were browsing when you accessed the “new document” function. Keep in
mind that you must have the appropriate access rights to insert an object into this
collection.

4. Enter a Title for the document and select a language from the menu. If you leave the
Title field blank, the title used is the file name without the extension, unless the file is of
type HTML, in which case the title is parsed from the HTML file.

5. A Name (unique identifier for the object being inserted) is optional. If you are using
JavaScript and did not enter a name, a name, consisting of the name of the parent
collection and the file name separated by a slash (unless the file is an HTML file, in which
case the file name without the extension is used) will automatically appear in the Name

field after you press the “Insert file” button. Thus, if the file hyperwave.gif is
inserted into a collection with the name “graphics”, the suggested name is
“graphics/hyperwave.gif”.

6. Click on “More” to enter additional attributes. The Base and MimeType attributes are
explained below; all other attribute types are explained on page 74. The Custom

Attribute field allows you to enter an attribute with the name and value of your choice.

7. Enter the full path for the file you want to insert or use the file browser to select a file.

8. Click on the “Insert file” button.

The Base attribute is necessary for texts and is by default the name of the server you are currently
connected to, e.g. http://www.hyperwave.com. The value of Base is used as base for the
links in the HTML text, i.e. a link that looks like this

<A HREF=”telephone_list.html”>Telephone numbers</A>

in your HTML text will, with the above mentioned base attribute, point to

http://www.hyperwave.com/telephone_list.html .

INSERTING FILES USING
OLDER BROWSERS

THE BASE ATTRIBUTE
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MimeType is used to tell Hyperwave the type of file being uploaded. It is entered by selecting a
MIME type from those available in the listbox. In many cases it is possible to take the default
“automatic detection” option because Hyperwave uses a so-called magic number test to figure out
the file type, and, if you use Netscape, many further file types are recognized by their extensions.
The following MIME types are recognized by Hyperwave:

MIME type File type

text/html HTML text
application/postscript PostScript files
image/jpeg JPEG images
image/gif GIF images
image/x-png PNG images
video/mpeg MPEG videos
video/x-avi AVI videos
x-world/x-vrml VRML 3D scenes
audio/x-wav WAV audio
audio/x-au AU audio
application/x-java Java classes

2.3.4.2� INSERTING COLLECTIONS
There are five types of collections: Collection, Language Cluster, Sequence, Multi Cluster and
Alternative Cluster.

· Collection

Collections are used to hold documents and other collections.

· Language Cluster

A Language Cluster is a collection which functions as a multilingual document. If you
insert two or more different texts into a cluster, each in a different language, then when
the cluster is accessed the text which corresponds to the language the user has set will be
displayed.

· Sequence

If you insert documents into a sequence, then when a member of the sequence is accessed,
buttons appear which let you navigate sequentially, forwards or backwards, through the
members.

· MultiCluster

All documents which have been inserted into a multicluster are displayed as a composite
document when the multicluster is accessed.

· AlternativeCluster

An alternative cluster is a collection of documents from which exactly one document is
chosen by certain criteria. The behavior of such a cluster is more like that of a simple
document than a collection.

Two typical applications for alternative clusters are

· To allow a choice between documents which have different levels of quality but

the same type (MimeType). A typical application are images with different resolutions
or color depth which represent the same content, but consume different amounts of
space. A user with low network bandwidth is able to receive an image with less quality in
a reasonable amount of time.

· To allow a choice between documents in different representations which do not

have the same type (MimeType). Sometimes it is necessary to offer information in
different data formats or media types. For instance, an announcement may be available
in PostScript, HTML, sound or even video format. Users can set their preferred
document type.

MIMETYPE

COLLECTION TYPES
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Rules for choosing a document from an alternative cluster:

1. If the alternative cluster has a MimeType set then only documents of this MimeType

are taken into account.

2. These documents are compared to the PrefMimeTypes (preferred MIME types which
are stored in the user record) from left to right. Documents with the best matching
MimeType are kept for further processing.

3. From these documents (all with the same MimeType) the ones with the smallest
difference in quality compared to the quality given with the matching MimeType in the
PrefMimeTypes field are selected.

4. If the resulting set contains more than one document, the one with the best matching
language is chosen.

5. Alternative clusters can be nested.

Collections are inserted as follows:

1. Log in to the server by clicking on Login.

2. Click on Authoring to switch to authoring mode.

3. Navigate to the collection you want to insert the collection into. Select
Publish→Collection. The “New Collection” window appears (see Figure 27). Keep in
mind that you must have the appropriate access to the collection where you want to insert
the collection.

4. Enter a Title for the new collection including a language from the listbox.

5. Enter a description for the collection if desired.

6. Enter a Name for the collection. Names should be given hierarchically, e.g. if you are
inserting the collection into the collection “smith”, and it is a collection for papers, you
should call the new collection “smith/papers”.

7. By clicking on the “more” button, you can add further attributes, including a Custom

Attribute with the type and value of your choice. An explanation of available attribute
types and their values is found on page 74.

8. Click on the “OK” button.

The procedure for inserting clusters is the same as that for inserting collections except that you
must select Publish→Cluster and the cluster type of your choice in step 3. See page 43 for a
description of collection types.

The procedure for inserting sequences is the same as that for inserting collections except that you
must select Publish→Sequence in step 3. See page 43 for a description of collection types.

INSERTING COLLECTIONS
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Figure 27: Inserting a collection

With older browsers, collections, clusters and sequences are inserted as follows:

1. Log in, switch to edit mode by clicking on the “EDIT” icon, and click on the “new

collection” icon ( ) to access the “new collection” form (see Figure 27).

2. Select the desired collection type from the list box. See below for an explanation of the
different collection types.

3. Type the Name or GOid attribute of the collection you want to insert the new collection
into in the “into collection” field. By default the collection is inserted into the collection
you were browsing when you accessed the “insert collection” function.

4. Enter a Title for the new collection including a language from the menu.

5. Enter a Name for the collection. Names should be given hierarchically, i.e. if you are
inserting the collection into the collection “smith”, and it is a collection for papers, you
should call the new collection “smith/papers”.

6. By clicking on the “more” button, you can add a new attribute from the menu, including
a Custom Attribute with the type and value of your choice. An explanation of available
attribute types and their values is found on page 74.

7. Press the Insert collection button.

2.3.4.3� INSERTING HTML AND TEXT
HTML and plain text can be inserted into Hyperwave not only in the form of files; they can also be
entered by hand just before being uploaded. This is done as follows with version 4.x browsers:

1. Log in to the server by clicking on Login.

2. Click on Authoring to switch to authoring mode.

3. Navigate to the collection you want to insert the text into. Select Publish→HTML or
Publish→Text depending on what you want to upload. The “New Text” window
appears. Keep in mind that you must have the appropriate access to the collection where
you want to insert the text.

4. Enter a Title for the new text including a language from the listbox.

5. Enter a description for the text if desired.
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6. Enter the text in the large window in the form (see Figure 28). With the “Text” option,
the text should be plain ASCII text, and with the “HTML” option, it should be
syntactically correct HTML.

7. Click on “More” to enter additional attributes. All attribute types are explained on page
74. The Custom Attribute field allows you to enter an attribute with the name and value
of your choice.

8. Click on the “OK” button.

When using older browsers, text and HTML are uploaded as follows:

1. Log in, switch to edit mode by clicking on the “EDIT” icon, and click on the “new

document” icon ( ) to access the “new document” form.

2. Select the “Text” or “HTML” tab to enter plain text or HTML respectively.

3. Enter the text in the large window in the form. With the “Text” option, the text should be
plain ASCII text, and with the “HTML” option, it should be syntactically correct HTML.

4. Enter the Name or GOid of the collection you want to insert the text into. Default is the
collection you were browsing when you accessed the “new document” function. Keep in
mind that you must have the appropriate access rights to insert an object into this
collection.

5. Enter a title for the text and select a language from the menu.

6. A Name (unique identifier for the text being inserted) is optional.

7. Click on “More” to enter additional attributes. All attribute types are explained on page
74. The Custom Attribute field allows you to enter an attribute with the name and value
of your choice.

8. Click on the “Insert text” button.
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Figure 28: Inserting an HTML text

2.3.4.4� INSERTING NOTES
It is possible to attach a note to any Hyperwave object. By default, annotated objects display a link
to their annotations in their footer.

1. Log in to the server by clicking on Login.

2. Click on Authoring to switch to authoring mode.

3. Select Publish→Note. The “New Note” window appears.

4. Navigate to the collection or document you want to annotate. If you want to annotate the
entire document, click on the “Whole Document” button. If you want to annotate a
specific word or phrase in the document, mark that phrase and click on the “Current
Selection” button.

5. Enter the text of the annotation in the large window. This text can be plain text but
HTML markup is allowed. However, the HTML header and footer are automatically
added to the text so what you enter in the form should only contain elements which are
allowed in the <BODY> section of an HTML text. Note that if you enter plain text,
carriage returns will be ignored unless you enter a <P> or <BR> tag. After the annotation
is inserted, a link from the annotation to the annotated object is automatically made.

6. Give the note a title and select a language from the list. Default is the title of the object
you are annotating, preceded by the text “Comment on”.

7. Enter the Name attribute of the collection you want to insert the annotation into. Default
is the collection you were browsing when you opened the “New Note” window.

8. Enter a Name attribute for the note. Optionally enter a description.

INSERTING NOTES USING
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9. Select the access rights for the annotation. “Public annotation” makes the annotation
readable by all users, “Private annotation” makes it readable by its author only, and
“Inherited” causes the annotation to have the same access rights as the collection it is
being inserted into.

10. Click on the “OK” button.

Figure 29: The New Note window

1. Log in and click on the “ANNOTATE” icon to access the Annotation Wizard.

2. Navigate to the collection or document you want to annotate. If you want to annotate the
entire document, click on the corresponding “Set” button. If you want to annotate a
specific word or phrase in the document, mark that phrase and click on the “Set current
selection” button. In some older browsers you may have to enter the phrase by hand after
pressing the “Set” button.

3. Enter the text of the annotation in the large window in the Annotation Wizard. This text
can be plain text but HTML markup is allowed. However, the HTML header and footer
are automatically added to the text so what you enter in the form should only contain
elements which are allowed in the <BODY> section of an HTML text. Note that if you
enter plain text, carriage returns will be ignored unless you enter a <P> or <BR> tag.
After the annotation is inserted, a link from the annotation to the annotated object is
automatically made.

INSERTING NOTES USING
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4. Enter the Name attribute of the collection you want to insert the annotation into. Default
is the collection you were browsing when you opened the Annotation Wizard.

5. Give the annotation a title. Default is the title of the object you are annotating, preceded
by the text “Comment on”.

6. Optionally give the annotation a Name attribute.

7. Select the access rights for the annotation. “Public annotation” makes the annotation
readable by all users, “Private annotation” makes it readable by its author only, and
“Inherited” causes the annotation to have the same access rights as the collection it is
being inserted into.

8. Click on the “Insert annotation” button.

2.3.4.5� INSERTING REMOTE DOCUMENTS
Hyperwave lets you insert remote objects into the server. Remote objects are references to objects
on other servers, e.g. WWW or FTP servers.

1. Log in to the server by clicking on Login.

2. Click on Authoring to switch to authoring mode.

3. Navigate to the collection you want to insert the remote document into. Select
Publish→Remote Document. The “New Remote Document” window appears. Keep in
mind that you must have appropriate access to the collection where you want to insert the
remote document.

4. Give the remote document a title and select a language from the list.

5. Enter the URL of the remote object you want to access with the Hyperwave remote
document. See below for details about what types of URLs can be entered.

6. A Name (unique identifier for the object being inserted) and description for the remote
document are optional.

7. Click on “More” to enter additional attributes. All attribute types are explained on page
74. The Custom Attribute field allows you to enter an attribute with the name and value
of your choice.

8. Click on the “OK” button.

1. Log in, switch to edit mode by clicking on the “EDIT” icon and click on the “new

document” icon ( ) to access the “new document” form.

2. Select the “Remote Document” tab to access the proper form.

3. Enter the URL of the remote object you want to access with the Hyperwave remote
document. See below for details about what types of URLs can be entered.

4. Enter the Name or GOid of the collection you want to insert the remote object into.
Default is the collection you were browsing when you accessed the “new document”
function. Keep in mind that you must have the appropriate access rights to insert an
object into this collection.

5. Enter a title for the document and select a language from the menu.

6. A Name (unique identifier for the object being inserted) is optional.

7. Click on “More” to enter additional attributes. All attribute types are explained on page
74. The Custom Attribute field allows you to enter an attribute with the name and value
of your choice.

8. Click on the “Insert remote document” button.

It is possible to insert documents of types “http”, “https”, “ftp”, and “telnet”. The URL is entered
using the protocol type followed by “://”, then the address. Some examples are

http://www.icg.tu-graz.ac.at/magellan

for a WWW document, and
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ftp://ftp.iicm.edu

for an FTP connection.

For telnet connections, the URL is entered in the following form:

telnet://user@host.

Figure 30: Inserting a remote document

This option is only available for system users and is explained in the Hyperwave Administrator’s
Guide.

2.3.5� THE “MODIFY” MENU

This menu lets you access all functions for modifying objects on the server, e.g. moving and
deleting objects, creating and modifying links, etc. You can use these functions as long as you have
appropriate access rights for the documents and links you want to modify.

The Modify menu contains the following items:

· Attributes: Lets you view and edit the attributes of any object.

· Edit Text: HTML and plain text documents can be edited.

· Hyperlink: Lets you add, modify or delete hyperlinks in HTML text.

· Move: Allows you to move documents and collections from one collection to another.

· Shortcut: Lets you create a shortcut from a collection to a collection or document.

· Duplicate: Makes duplicate (real copy and not a shortcut) of a document.

· Delete: Deletes documents and collections.

· Replace: Lets you replace an existing document.

· Workflow-Release Procedures: Allows you to set up a chain of users for the systematic
review of documents.

INSERTING CGI OBJECTS
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· Version Control: Version control allows you to save all versions of a document ever
created.

· Lock/Unlock Object: Lets you lock/unlock documents.

These menu items are explained in greater detail below.

2.3.5.1� ATTRIBUTES
If you have appropriate access rights for an object you can edit some of its attributes. Title and
Name (a unique identifier assigned to the object) are editable if you are the owner of the object.
Other attributes, such as TimeCreated (the time the object was inserted into Hyperwave),
DocumentType (e.g. text, image) and GOid (a unique number which is assigned to the object
when it is created and which can be used to identify the object) are maintained by the server and
cannot be changed.

Figure 31: Editing attributes

Attributes are edited as follows when using version 4.x browsers:

1. Log in to the server by clicking on Login.

2. Click on Authoring to switch to authoring mode.

3. Navigate to the document or collection whose attributes you want to modify.

4. Select Modify→Attributes. The list of the object’s attributes appears (see Figure 31).
Some of them can be edited.

5. Click on the “more” button at the bottom of the attribute list to add a new attribute using
the menu and field at the bottom of the list. Under Custom Attribute you can enter a
completely new attribute with the desired name and give it an arbitrary value.

6. When you are finished editing the attributes, click on the “OK” button.
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Attributes are edited as follows when using older browsers:

1. Log in and switch to edit mode by clicking on the “EDIT” icon.

2. Navigate to the document or collection whose attributes you want to modify.

3. Click on the “edit attributes” icon ( ). The list of the object’s attributes appears. Some
of them can be edited.

4. Click on the “more” button at the bottom of the attribute list to add a new attribute using
the menu and field at the bottom of the list. Under Custom Attribute you can enter a
completely new attribute with the desired name and give it an arbitrary value.

5. When you are finished editing the attributes, click on the “Apply Attributes” button.

Note: Certain attributes, such as Title and Name, can be entered multiple times. You can have, e.g.
several different Name attributes and thus have several different URLs which you can use to access the
same object.

When editing attributes, it is possible to view the references to and from a document by clicking
on the “Link Map” button in the attributes window. This allows you to see the incoming and
outgoing links for an object, as well as its parent collection(s) and children documents.

2.3.5.2� EDITING TEXT
The “Edit Text” function lets you edit HTML or plain text documents.

1. Log in to the server by clicking on Login.

2. Click on Authoring to switch to authoring mode.

3. Navigate to the text you want to edit. Select Modify→Edit Text. The “Edit Text”
window appears. Edit the text.

4. Click on the “OK” button.

1. Log in, switch to edit mode by clicking on the “EDIT” icon, and navigate to the text you
want to edit.

2. Click on the “modify objects” icon ( ). The Modify Wizard appears.

3. Click on the “Text” tab.

4. Edit the text.

5. Click on the “Modify text” button.

Note: If you edit a plain text document, any links present in the document will be deleted when you
upload the modified document.

You may be wondering about the numbers that appear after links in the source text of HTML
documents (see Figure 32). They are unique link identifiers which ensure that your links remain
consistent even if you move the destination document to another collection. When they appear it
means that the link is closed, i.e. the link destination exists in your system. If you want to change a
link to point to another object you need to remove its link ID, otherwise the link will continue
pointing to the previous destination.
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Figure 32: Editing HTML text

2.3.5.3� ADDING/MODIFYING/DELETING HYPERLINKS
The Modify menu allows you to create, edit or delete hyperlinks in HTML texts.

Links can be created in Hyperwave using the Link Wizard (note that you must have JavaScript 1.1
or higher to use the Wizard). It is possible to create links in HTML and plain text. Please note that
at this time, links created in plain text documents are deleted if the text is edited.

1. Log in to the server by clicking on Login.

2. Click on Authoring to switch to authoring mode.

3. Select Modify→Hyperlink→Add Hyperlink. The Link Wizard appears.

4. Set the link start. This is done by navigating to the document where you want the link
start, selecting the desired word or phrase with the mouse and clicking on the “Current
Selection” button near the top of the window. The marked phrase and the title of the
document appear in the respective fields.

5. Use the radio buttons to decide what to do if the selected phrase appears more than once
in the text.

6. Select the link type. You can create a normal reference link, an annotation, or an inline
image. Add optional access rights for the link using the Rights Wizard.

7. Set the link target. Navigate to the document where you want the link target. To set the
entire document as target, click on the “Whole Document” button. To set a phrase as
target, select the phrase and click on the “Current Selection” button.

8. Click on the “OK” button.

1. Log in, switch to edit mode by clicking on the “EDIT” icon, and click on the “make link”

icon ( ) to access the Link Wizard.

2. Set the link start. This is done by navigating to the document where you want the link
start, selecting the desired word or phrase with the mouse and clicking on the “Set”
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button near the top of the window. The marked phrase and the title of the document
appear in the respective fields. In some older browsers the phrase does not automatically
appear in the corresponding field when you press “Set”. In this case you must enter the
phrase by hand.

3. Use the radio buttons to decide what to do if the phrase is not unique in the document.

4. Add an optional title and access rights for the link, and select the link type. See below for
an explanation of these attributes.

5. Set the link target. Navigate to the document where you want the link target. To set the
entire document as target, click on the appropriate “Set” button. To set a phrase as target,
select the phrase and click on the “Set current selection” button. In some older browsers
you may have to enter the phrase by hand after clicking on “Set”.

6. Click on the “Create link” button.

Note: If your local server is part of a server pool, it is possible to make links from the local server to
another server in the pool. The only difference is that when setting the link target you have to navigate
to the remote server over the “Hyperwave Serverpool” collection, which is found in the root collection.

Figure 33: The Link Wizard

The Link Wizard can be used to give various attributes to the links created if desired. These
attributes include Title, Rights, and link type (reference, annotation or inline).

Giving a link a Title can help you find the link during a search. Rights are used to control who can
see the link, e.g. you can give a document and a link in the document different rights so that the
users who can read the document do not necessarily see the link.

LINK ATTRIBUTES
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There are three different link types: “Reference”, “Annotation” and “Inline image”. “Reference”
links are normal links. “Annotation” links are links from an annotation to the annotated
document (see page 47). “Inline image” links are links from an HTML text to an image, which
cause the image to appear in the text.

1. Log in to the server by clicking on Login.

2. Click on Authoring to switch to authoring mode.

3. Navigate to the document whose hyperlinks you want to edit. Select
Modify→Hyperlink→Modify Hyperlink. The Modify Hyperlinks window appears,
displaying the document with an “attributes” icon next to each link (see Figure 34). Click
on one of these icons to access the attributes of the link. A list of the link’s attributes
appears.

4. It is possible to change the Owner attribute of the link (if you are a member of the group
“system”) or change or add a Title or Rights attribute. Click on “More” to add an
additional attribute (see page 74 for a list of attribute types with explanations) or a custom
attribute (attribute with an arbitrary name and value).

5. Click on the “OK” button.

1. Log in, switch to edit mode by clicking on the “EDIT” icon, and navigate to the text
whose links you want to edit.

2. Click on the “modify objects” icon ( ). The Modify Wizard appears.

3. Click on the “Edit Links” tab. The document is displayed with an “attributes” icon next
to each link. Click on an icon to access the attributes of the link.

4. Click on the “edit” button to edit the link attributes. It is possible to change the Owner of
the link (if you are a member of the group “system”) or change or add a Title or Rights

attribute. Click on “More” to add an additional attribute (see page 74 for a list of attribute
types with explanations) or a custom attribute (attribute with an arbitrary name and
value).

5. Click on the “Apply attributes” button.
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Figure 34: Links displaying links to their attributes

1. Log in to the server by clicking on Login.

2. Click on Authoring to switch to authoring mode.

3. Navigate to the text whose links you want to delete and select
Modify→Hyperlinks→Delete Hyperlink. The “Delete Hyperlinks” window appears.

4. Use the checkboxes to select the links you want to delete.

5. Click on the “OK” button.

1. Log in, switch to edit mode by clicking on the “EDIT” icon, and navigate to the text
whose links you want to delete.

2. Click on the “modify objects” icon ( ). The Modify Wizard appears.

3. Click on the “Delete Links” tab. The document is displayed with a checkbox next to each
link. Use the checkboxes to select the links you want to delete.

4. Click on the “Delete Links” button.

2.3.5.4� MOVING OBJECTS
Objects are moved as follows when using Hyperwave with 4.x browsers:

1. Log in to the server by clicking on Login.

2. Click on Authoring to switch to authoring mode. The items in the collection hierarchy
appear with a checkbox next to each.

3. Navigate to the collection which contains the items you want to move. Use the
checkboxes to select one or more items.

4. Select Modify→Move. In the window that appears, select the target collection for the
object(s) to be moved.

5. Click on the “OK” button.

Objects are moved as follows when using older browsers:

1. Log in, switch to edit mode by clicking on the “EDIT” icon, and navigate to the collection
which contains the object(s) you want to move.

2. Click on the “modify objects” icon ( ). The Modify Wizard appears, displaying the
collection you were just browsing with a checkbox next to each item.

3. Click on the “Move” tab.

4. Select the objects you want to move using the checkboxes.

5. Enter the Name or GOid attribute of the collection you want to move the object(s) to in
the “Move documents to collection” field.

6. Click on the “Move selected documents” button.

2.3.5.5� MAKING SHORTCUTS TO OBJECTS
A shortcut is a link to a Hyperwave object. If you make a shortcut to an object, it appears as if this
object is contained in the collection. However, only one physical copy of it exists on the server. If
you want to make a real copy of an object on the server, use the “duplicate” function.

1. Log in to the server by clicking on Login.

2. Click on Authoring to switch to authoring mode. The items in the collection hierarchy
appear with a checkbox next to each.

3. Navigate to the collection which contains the items you want to make shortcuts to. Use
the checkboxes to select one or more items.

4. Select Modify→Shortcut. In the window that appears, select the target collection for the
object(s) to be linked.
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5. Click on the “OK” button.

Shortcuts to objects are made as follows when using older browsers. Note that the “shortcut”
function was previously called the “link” function.

1. Log in, switch to edit mode by clicking on the “EDIT” icon, and navigate to the collection
which contains the object(s) you want to link.

2. Click on the “modify objects” icon ( ). The Modify Wizard appears, displaying the
collection you were just browsing with a checkbox next to each item.

3. Click on the “Link” tab.

4. Select the objects you want to link using the checkboxes.

5. Enter the Name or GOid attribute of the collection you want to link the object(s) to in
the “Link documents to collection” field.

6. Click on the “Link selected documents” button.

Note: If your local server is part of a server pool, it is possible to link documents from another server in
the pool to a collection on your server. The only difference is that in step one you have to navigate to
the remote server over the “Hyperwave Serverpool” collection, which is found in the root collection.

2.3.5.6� DUPLICATING OBJECTS
The “duplicate” function makes an actual physical copy of a document on the server.

Documents are duplicated as follows when using Hyperwave with 4.x browsers:

1. Log in to the server by clicking on Login.

2. Click on Authoring to switch to authoring mode. The items in the collection hierarchy
appear with a checkbox next to each.

3. Navigate to the collection which contains the items you want to duplicate. Use the
checkboxes to select one or more items. Note that it is not possible to copy collections.

4. Select Modify→Duplicate. In the window that appears, select the target collection for the
duplicated object(s).

5. Click on the “OK” button.

Documents are duplicated as follows when using older browsers. Note the “duplicate” function
was previously called the “copy” function.

1. Log in, switch to edit mode by clicking on the “EDIT” icon, and navigate to the collection
which contains the document(s) you want to copy.

2. Click on the “modify objects” icon ( ). The Modify Wizard appears.

3. Click on the “Copy” tab. All member documents of the collection you were just
browsing will be displayed with a checkbox next to each. Note that it is not possible
to copy collections.

4. Select the documents you want to copy using the checkboxes.

5. Enter the Name or GOid attribute of the collection you want to insert the copied
document(s) into in the “Copy documents into collection” field.

6. Click on the “Copy selected documents” button.

2.3.5.7� DELETING OBJECTS
Objects are deleted as follows when using Hyperwave with version 4.x browsers:

1. Log in to the server by clicking on Login.

2. Click on Authoring to switch to authoring mode. The items in the collection hierarchy
appear with a checkbox next to each.

3. Navigate to the collection which contains the object(s) you want to delete and use the
checkboxes to select one or more documents to be deleted.
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4. Select Modify→Delete and click on “OK” in the window that appears. The objects will
be permanently deleted.

Objects are deleted as follows when using older browsers:

1. Log in, switch to edit mode by clicking on the “EDIT” icon, and navigate to the collection
which contains the object(s) you want to delete.

2. Click on the “modify objects” icon ( ). The Modify Wizard appears, displaying the
collection you were just browsing with a checkbox next to each item.

3. Click on the “Delete” tab.

4. Select the objects you want to delete using the checkboxes.

5. Click on the “Delete selected documents” button. The checked objects will be
permanently deleted.

Note: The delete function is recursive, i.e. you can delete a collection even if it contains other
documents and collections.

2.3.5.8� REPLACING DOCUMENTS
1. Log in to the server by clicking on Login.

2. Click on Authoring to switch to authoring mode.

3. Navigate to the document you want to replace and select Modify→Replace. The
“Replace” window appears, displaying a list of the attributes of the current document.
There are fields where you can enter a base attribute and a file name.

4. Enter a base if you are replacing a text (the value of this attribute is used as a base for the
links in the document if it is an HTML document).

5. Enter a file name including the path, or select a file using the file browser.

6. Click on the “OK” button.

1. Log in, switch to edit mode by clicking on the “EDIT” icon, and navigate to the
document you want to replace.

2. Click on the “modify objects” icon ( ). The Modify Wizard appears.

3. Click on the “Replace Document” tab. A list of the attributes of the current document is
displayed. There are fields where you can enter a base attribute and a file name.

4. Enter a base if you are replacing a text (the value of this attribute is used as a base for the
links in the document, if it is an HTML document).

5. Enter a file name including the path, or select a file using the file browser.

6. Click on the “Replace document” button.

2.3.5.9� WORKFLOW: RELEASE PROCEDURE
Release Procedure is an extremely useful and efficient Hyperwave feature for the systematic review
of documents. Using Release Procedure, a predefined chain of users can be set up and used to
circulate, review, edit and release documents within a system.

Once a procedure (flow) has been created, many cases (instances of a procedure) can be started
based on its structure. Each procedure has an administrator, a publisher, auditors and possibly
readers.

The administrator is the user with the rights to edit the procedure.

The publisher is the user who is responsible for editing documents, assigning documents to a case,
creating cases and releasing them to the auditors, and receiving documents for reworking in the
case of rejection.

The auditors are the users who are responsible for reviewing documents. Each auditor who
accesses the Case collection has the choice of either releasing or rejecting the case. If the case is
released, it is passed on to the next auditor in the list, if it is rejected, it is returned to the publisher

DELETING OBJECTS USING
OLDER BROWSERS

REPLACING DOCUMENTS
USING VERSION 4.X

BROWSERS

REPLACING DOCUMENTS
USING OLDER BROWSERS

INTRODUCTION
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for reworking. Auditors add comments to the case, explaining their reasons for releasing or
rejecting it.

Readers are users who are assigned read rights to documents in the Release collection, once
documents have been released. Readers do not actively take part in the reviewing process.

Let us take an example. A department head writes a report on his department’s projected sales
figures for the quarter. Before this document is made available to all the employees in the
company, it must first be reviewed by two other department heads, the accounts manager and the
sales manager. DepartmentHead1 is therefore the publisher and the other department heads and
the managers are auditors. When the administrator is creating a new procedure, he enters a list of
user names as auditors. The order in which the names are entered, e.g. DepartmentHead2 >
DepartmentHead3 > AccountsManager > SalesManager, is exactly the order in which documents
are circulated for review.

Auditors receive notification that a case is to be reviewed. When the auditor navigates to the Case
collection, the case is displayed in the interface with a comment box and two option buttons
underneath it, Release and Reject. The auditor can choose to release the case, sending it on to the
next auditor or back to the publisher if this auditor is the last on the list, or to reject the case,
sending it back to the publisher for editing. The auditor can also add an optional comment,
regarding the reasons for releasing or rejecting the case. These comments are stored in the Case
collection, along with the documents.

When a case is rejected, the rejected documents and their comments are inserted into a folder in
the collection. This folder is labeled Rejection and includes the relevant date and time.

When the publisher feels the returned document has been sufficiently revised, the case is started
again and the release procedure started anew. Documents that are released for the second time
must be sent through all auditors again, not just to the auditor who rejected the case.

The menu items under Release Procedure are as follows: New Release Procedure, Edit Release
Procedures, Assign Release Procedure, Show open Cases, Create Cases, Start Case, Delete Case
and Show state of the Case. These items are explained in detail below.

EXAMPLE

REVIEWING DOCUMENTS

RELEASE PROCEDURE
MENU
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Figure 35: Release Procedure Menu

When creating a new release procedure, the administrator must enter the following information:

Procedure Name: the name the procedure is to have. This should be descriptive.

Description: a short description of the procedure, which will appear on the interface next to the
collection listing.

Administrators: the user(s) with the rights to edit the procedure

Publishers: the user(s) that assigns documents to procedures and starts cases

Auditors: the user(s) who are to review documents. These user names must be entered in the
order in which they are to receive documents.

Note: For all cases where there is a user name or list of user names to be entered, there is a button that
will open the User Wizard, allowing the administrator to choose user names easily from a list.

There are two checkboxes, allowing the user to decide which notification options are to be used. If
the option Show open cases at login is selected, a pop-up window will appear when the publisher
or auditor logs into the Hyperwave Server. If the option inform per e-mail is selected, the
publisher or auditor will receive an e-mail detailing the status of cases in which they are involved.
For more information on notification, see page 66.

CREATING A NEW
PROCEDURE
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Release collection: here the name of the collection is entered, where documents assigned to
release procedures can be stored. It is also possible to edit and release documents from their
original location.

The next two check boxes allow the administrator to manage the Release collection into which
release flow documents are inserted:

By clicking Published documents can only be stored in the "Release collection", the
administrator ensures that the value inserted for Release collection (see above) cannot be
changed. All release flow documents must then be stored in this collection, and the value cannot
be edited at other stages (e.g. in the Assign Documents to Release Procedure dialog box).

By clicking Copy Documents to Release Collection, the administrator ensures that a working
copy of all release flow documents is stored in the Release collection. The advantage of choosing
this option is that working copies of documents to be reviewed are created in a separate release
collection, and the initial versions of the documents still exist in their original collection.

Readers: the user(s) that have read rights to documents in the Release collection. These users can
access documents when they are released but have no active part in the review procedure. If no
users are specified as Readers at this point, read rights for the Release collection will be given to all
users.

Detailed description: a detailed description of the procedure, which is listed in the text file
version of the procedure description. This is an administrative document, which shows attributes
and values associated with the procedure.

The following steps explain how to create a new release procedure:

1. Log onto the server by clicking on Login.

2. Click on Authoring to switch to authoring mode.

3. Select Modify →Release Procedure→New Release Procedure.

4. In the dialog box that appears, input the appropriate information as discussed above

5. Click OK.
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Figure 36: New Release Procedure dialog box
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The following steps explain how to edit a release procedure. In order to edit a procedure, the
user must have been assigned as administrator when the procedure was first created.

1. Log onto the server by clicking on Login.

2. Click on Authoring to switch to authoring mode.

3. Select Modify →Release Procedure→Edit Release Procedure…

4. A dialog box will appear with a list of all release procedures. Click on the edit button
beside the procedure you wish to modify.

5. In the dialog box that appears, modify the appropriate information.

6. Click OK.

Once release procedures have been set up, instances of these procedures (cases) can be created
and one or more documents can be assigned.

The following steps explain how to assign a document to a release procedure.

1. Log on to the server by clicking on Login.

2. Click on Authoring to switch to authoring mode.

3. Navigate to the collection containing the documents you wish to assign.

4. Select the document(s) you wish to assign to a release procedure using the checkboxes.

5. Select Modify →Release Procedure→Assign Release Procedure 

6. A dialog box appears listing all currently existing release procedures. Choose the
procedure you wish to assign the documents to, using the radio buttons.

7. The default Release collection for these documents appears in a text box. You can edit
this collection name as long as the option Published documents can only be stored in

the "Release collection" was not checked in the New Release Procedure dialog box (see
Figure 36). It is at this point that working copies of the documents are copied into the
Release collection (if this was chosen when Creating a New Procedure).

8. If you wish to release the documents to the reviewers immediately, check the option Start

Case immediately, and input a Case title. Checking this option skips the step Create

Case.

If this option is not checked, the next step is to create the case. See page 65 Click OK.

EDITING A RELEASE
PROCEDURE

ASSIGNING DOCUMENTS
TO A RELEASE PROCEDURE
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Figure 37: Assign Documents to Release Procedure dialog box

When documents being assigned contain inline images, and these images are not located in the
same collection as the documents to which they belong, an extra dialog box is displayed when the
documents are being assigned to a Release Procedure. This dialog box lists all inline images in the
selected document(s) and allows the publisher to select which ones are to be included in the release
procedure for review. These images then appear as separate documents in the Release collection.

It is also possible to assign these documents to separate flows, e.g. if the text document is to be
reviewed by the manager and the documentation specialist and the graphics are to be reviewed by
the manager and the graphic artist.

ASSIGNING DOCUMENTS
CONTAINING INLINE

IMAGES
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Figure 38: Selecting Inline Images

After documents have been assigned to a procedure, the publisher can then create the case. This
means that the publisher selects documents and creates instances of release procedures for those
documents. The publisher also assigns a Case title and either starts the case straight away or
prepares it for starting. If the documents selected are assigned to more than one release procedure,
all relevant cases will appear in the Create case dialog box.

The cases are stored in folders in the Release collection. These folders (Case collections) take their
names from the Case titles.

The Create Case dialog box appears (see Figure 39), allowing titles, and a language ID be
attributed to each case. Current language options are English and German. In this dialog box,
there is also a Start case immediately checkbox for each case, allowing the publisher to start the
case from within this dialog.

The first time a document is released to a procedure, it is likely that the steps Create Case and
Start Case will happen concurrently. However, as the review process continues, and documents
are returned to the publisher for editing and reworking, the publisher will create cases in order to
work on documents. Only when he has made the appropriate changes to the documents, will the
case then be started again (released to the procedure).

If the checkbox Start case immediately was selected in the previous step (Assigning Documents

to a Release Procedure), then the Create Case step is completely skipped.

The following steps explain how to create a case:

1. Log on to the server by clicking on Login.

2. Click on Authoring to switch to authoring mode.

3. Navigate to the collection containing the documents you wish to create a case for.

4. Using the checkboxes, select the document(s) you wish to create a case for.

5. Select Modify →Release Procedure→Create Case

6. In the dialog box that appears, for each case, type in a Case Title and select a language
attribute from the listbox. It is also possible to start the case from within this dialog box
by selecting the checkbox labeled Start Case immediately. This option is selected by
default.

CREATING CASES
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7. Click OK.

Figure 39: Create Case dialog box

As previously mentioned, it is also possible to start cases from within the Create Case dialog box.
When starting a case from within the Create Case dialog box, it is also required to input Case

Title and a language attribute (current options: English and German).

The following steps explain how to start a case using the Start Case option in the Release

Procedure menu. To start a case or cases from within the Assign Documents to a Release

Procedure dialog box, or from within the Create Case dialog box, see page 63and page 65.

1. Log on to the server by clicking on Login.

2. Click on Authoring to switch to authoring mode.

3. Navigate to the collection containing the case(s) you wish to start.

4. Select the case(s) you wish to start using the checkboxes.

5. Select Modify →Release Procedure→Start Case

6. Click OK.

When creating a new release procedure, there are two options to select for notification of cases to
be reviewed etc (see Figure 36). Notification can occur either by e-mail, by means of a pop-up
window at login, or both. Both methods of notification contain a link to the case in question.

The auditor who rejects a case will receive notification that the publisher has been informed of the
rejection, and the last auditor in a procedure will receive notification that the publisher has been
informed of the successful completion of the case.

STARTING CASES

NOTIFICATION
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Figure 40: Notification Pop-up

It is also possible at any time for auditors and publishers to check cases to be created, cases to be
started, and cases closed since last login by choosing the option Show Open Cases from the
Release Procedure menu. See Viewing Open Cases, below.

The following steps explain how to view all open cases.

1. Log onto the server by clicking on Login.

2. Click on Authoring to switch to authoring mode.

3. Select Modify →Release Procedure→Show Open Cases…

4.  A window will appear displaying all open cases. The cases are grouped under the
headings Cases to be started, Cases to be reviewed, and Closed Cases since last login.

The cases appear as links, which will bring the user directly to the appropriate case
collection.

5. Click OK.

Figure 41: Show Open Cases dialog box

The following steps explain how to view the status of a case.

1. Log onto the server by clicking on Login.

2. Click on Authoring to switch to authoring mode.

3. Navigate to the Case collection whose status you wish to view.

4. Select Modify →Release Procedure→Show State of Case

5. A window will appear displaying the status of the selected case. Possible values for the
release flow status are: not yet started, waiting for the review to begin, being

reviewed, being edited, released. The window also displays the date of the last review or
release, the last auditor to have released the case, the case publisher and the number of
documents in the case.

VIEWING OPEN CASES

VIEWING THE STATUS OF A
CASE
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6. Click OK.

Figure 42: Show State of Case dialog box

The following steps explain how to delete a case.

1. Log on to the server by clicking on Login.

2. Click on Authoring to switch to authoring mode.

3. Navigate to the collection containing the case you wish to delete.

4. Select the case(s) you wish to delete using the checkboxes.

5. Select Modify →Release Procedure→Delete Case

6. Click OK.

Note: by deleting a case, you remove it completely from the procedure to which it was assigned. All
duplicates of documents stored in the Release collection will be deleted. The original version of
documents is not affected by this action, nor is the procedure to which documents had been assigned.

2.3.5.10� VERSION CONTROL
Hyperwave’s Version Control feature lets you save and retrieve all the versions ever created of a
document on the Hyperwave Information Server. It encompasses four functions: check in, check

out, version history and revert to version.

Documents in Hyperwave are not automatically version controlled. If you want a document to be
version controlled, you must use the check in function on it. This assigns a version number to the
document (starting with 1.0), and makes it so that no one can edit it unless he or she has used the
check out function on it. When a user checks out the document, it is automatically locked for this
user, meaning that only this user can edit it until it is checked in again.

When a document has been checked out by a user, it is called an experimental version. After the
document has been checked in, the new version is called the last committed version.

With the version history function, you can view the complete version history of a document,
including the version number, the user who created the version and the time it was created. For
each entry in the list the title of the version with a link to that version is shown, so you can easily
view any version in the history.

DELETING A CASE

THE “CHECK IN” AND
“CHECK OUT” FUNCTIONS

EXPERIMENTAL AND LAST
COMMITTED VERSION

THE “VERSION HISTORY”
FUNCTION
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With the revert to version function you can go back to any version in the history of a document
and use it as the most recent version (last committed version).

The following steps explain how to check in several documents simultaneously.

1. Log in to the server by clicking on Login.

2. Click on Authoring to switch to authoring mode.

3. Navigate to the collection that contains the document(s) you want to check in. Use the
checkboxes to select the document(s).

4. Select Modify→Version Control→Check In.

The following steps explain how to check in a single document. Checking in a single document has
the advantage that you are given the option of manually changing the version number and you can
add a comment about the version.

1. Log in to the server by clicking on Login.

2. Click on Authoring to switch to authoring mode.

3. Navigate to the document you want to check in and select Modify→Version

Control→Check In. A window appears where you can change the document version
number (the “New version” field) and enter a comment about the changes in the version.
Note that the version number you enter must be greater than the most recent version
number.

4. Click on the “OK” button.

The following steps explain how to check out several documents simultaneously.

1. Log in to the server by clicking on Login.

2. Click on Authoring to switch to authoring mode.

3. Navigate to the collection that contains the document(s) you want to check out. Use the
checkboxes to select the document(s).

4. Select Modify →Version Control→Check Out.

The following steps explain how to check out a single document.

1. Log in to the server by clicking on Login.

2. Click on Authoring to switch to authoring mode.

3. Navigate to the document you want to check out and select Modify→Version

Control→Check Out. A window appears, displaying information about the document
version.

4. Click on the “OK” button.

1. Log in to the server by clicking on Login.

2. Click on Authoring to switch to authoring mode.

3. Navigate to the document whose version history information you want to view.

4. Select Modify→Version Control→Version History. The version history appears. For
each version, the version number, time the version was created, version author, and a link
to the version appear.

1. Log in to the server by clicking on Login.

2. Click on Authoring to switch to authoring mode.

3. Navigate to the document for which you would like to revert to an earlier version.

4. Select Modify→Version Control→Revert to Version. Use the radio buttons to select
the version you would like to revert to and click on the “OK” button. All versions which
are later than the version you selected will be permanently deleted.

THE “REVERT TO VERSION”
FUNCTION

CHECKING IN MULTIPLE
DOCUMENTS WITH

VERSION 4.X BROWSERS

CHECKING IN SINGLE
DOCUMENTS WITH

VERSION 4.X BROWSERS

CHECKING OUT MULTIPLE
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VERSION HISTORY WITH
VERSION 4.X BROWSERS

REVERTING TO AN EARLIER
VERSION WITH 4.X
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1. Log in and switch to edit mode by clicking on the “EDIT” icon.

2. Navigate to the collection that contains the document(s) you want to use version control
on.

3. Click on the “version control” icon in the lower right half of the toolbar. What you see
now depends on which type of object you are browsing.

a. If you are currently browsing a collection, you will be able to check out any checked in
items or check in any checked out items in the collection by clicking on the “check out”
and “check in” tabs respectively. Select the item(s) you want to check in or check out
using the checkboxes and click on the button below the list of documents. See above for
details about these functions.

b. If you are currently accessing a document, you will see three tabs: “Document history”,
“Revert to version” and, depending on if the document is currently checked in or out,
either “check out” or “check in” respectively. See above for an explanation of these
functions. You can check out a document simply by clicking on the “Check out
document” button. When you check in a document, you may enter two things: the
version number you want to give it and an optional comment.

 The version number consists of a major version number and a minor version number
separated by a point. When checking in the document  you have the choice of taking the
default version number or specifying one yourself. By default, the minor version number
is raised by one, e.g., if you checked out version 2.3, the new version will be 2.4. If you
want to change this number, e.g. raise the major version number, you can do it by hand
before checking in the version. In this case the new major version number must be
greater than or equal to that of the last version.

 A comment can be made in the box in the middle of the check in window.

Figure 43: Checking in a document

When browsing a version controlled document, the version you see depends on whether the
document is currently checked in or checked out and what your access rights to the document are.
If it is checked in, you will see the last committed version. If it is checked out, you will see the last
committed version if you only have read rights, and the experimental version if you have write
rights. If you look at the attributes of a version controlled document, the value of HW_Version

(see below) is the version number if the document is checked in or if you have only read rights. If
you have write rights to the object, its value is “experimental”, to show that a user has locked the
object.

USING VERSION CONTROL
WITH OLDER BROWSERS

BROWSING VERSION
CONTROLLED DOCUMENTS
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When you check in a new version of a document, by default it gets the same access rights as the
previous version. It is, however, possible to edit the attributes of each version to give each one
different access rights. If the document is accessed e.g. by a link, the rights attribute of the newest
version is used to determine if the document is displayed or not.

If a version controlled document is deleted, then ALL versions of the document are deleted. It is
not possible to delete single versions of a document. With “revert to version” (see above) it is
possible to delete all versions of a document that have a higher version number than a specified
version.

Version controlled documents have four specialized attributes:

· HW_VersionOwner

The value of this attribute is the Hyperwave user name of the user who checked in the
current version. This attribute is maintained by the system and cannot be edited.

· HW_VersionTime

The value of this attribute is the point at which the current version was checked in. It is
also maintained by the system and cannot be edited.

· HW_Version

This attribute tells you the version number of the document. This number consists of a
major version number and a minor version number separated by a point. When checking
in a document, you have the choice of taking the default version number or specifying
one yourself. By default, the minor version number is raised by one, e.g., if you checked
out version 2.3, the new version will be 2.4 unless you specify otherwise.

· HW_VersionComment

The value of this attribute is a comment which the person checking in the document can
optionally give to the document.

2.3.5.11� LOCKING AND UNLOCKING DOCUMENTS
Hyperwave allows users to lock their documents, i.e. it is possible for a user to designate that only
he or she can edit a particular document during a certain time period.

Documents can only be locked by their authors, other users who have write rights for the
document and users in the group “system”. When a document is locked, it can only be edited by
the person who locked it. Before other users can edit the document, the person who locked it or a
member of the group “system” must unlock it.

Note: Only documents, e.g. text, images, etc. can be locked and not other objects such as collections.

VERSION CONTROL AND
ACCESS RIGHTS

DELETING VERSION
CONTROLLED DOCUMENTS

SPECIAL ATTRIBUTES OF
VERSION CONTROLLED

DOCUMENTS
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DOCUMENT?
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Figure 44: A document that has been locked

1. Log in to the server by clicking on Login.

2. Click on Authoring to switch to authoring mode.

3. Navigate to the document you want to lock.

4. Select Modify→Lock Object.

1. Log in and switch to edit mode using the “EDIT” button.

2. Navigate to the document you want to lock.

3. Click on the “Lock Document” icon ( ) in the toolbar.

Once a document is locked, all users who view it in edit mode see a status line that says that the
document is locked and which includes the name of the user who locked it (see Figure 44).

1. Log in to the server by clicking on Login.

2. Click on Authoring to switch to authoring mode.

3. Navigate to the document you want to unlock.

4. Select Modify→Unlock Object.

1. Log in and switch to edit mode using the “EDIT” button.

2. Navigate to the document you want to unlock.

HOW TO LOCK
DOCUMENTS USING

VERSION 4.X BROWSERS

HOW TO LOCK
DOCUMENTS USING OLDER

BROWSERS

APPEARANCE OF LOCKED
DOCUMENTS

HOW TO UNLOCK
DOCUMENTS USING

VERSION 4.X BROWSERS
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3. Click on the “Unlock Document” icon ( ) in the toolbar.

2.3.6� THE “VIEW” MENU

The View menu lets you access object attributes, lock and use version control on documents, or
view a link map.

The View menu contains the following items:

· Attributes: Lets you view the attributes of any object (see page 51 for editing attributes).

· Header/Footer off: This switches on/off the Hyperwave header and footer in the default
user interface.

· Link Map: Generates a map of incoming and outgoing links for any object.

Figure 45: Viewing document references

2.3.6.1� LINK MAP
It is possible to generate a link map for any Hyperwave collection or document. The link map
displays incoming and outgoing links for the object (see Figure 45). All links associated with the
object are shown, including parent collections, reference links which point to the object and
annotation links to the object on the “into document” list, and children objects and reference links
that originate in the object on the “from document” list.

1. Log in to the server by clicking on Login.

2. Click on Authoring to switch to authoring mode.

3. Navigate to the document or collection for which you want to generate a link map. Select
View→Link Map.

GENERATING A LINK MAP
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2.4� OTHER ICONS ON THE TOOLBAR IN
HYPERWAVE VERSION 2.6

There are several icons that appear in the lower part of the toolbar in version 2.6 which have not
yet been mentioned in this guide. When they are active and what they do is explained below in the
order they appear on the toolbar.

·  The “Home” icon: This brings you to the global home collection on the server and is
always active.

·  The “Personal home” icon: This brings you to your personal home collection on the
server, if you have one and are identified.

·  The “Go up one level” icon: This brings you up one level in the collection hierarchy
and is visible unless you are in the root collection.

·  The “Go back to document” icon: If you are using one of the Hyperwave functions,
e.g. search, insert document, etc. this brings you back to the page you were browsing when
you accessed the function.

·  The “Disable header and footer” icon: This is used to turn off the Hyperwave header
and footer for the current object.

·  The “Attributes” icon: This shows you the attributes of the document or collection
you are currently browsing. If you are in edit mode, the attributes are in their editable state.

2.5� ATTRIBUTE TYPES

Below is a list which explains the attribute types briefly with examples in alphabetical order. This
list contains attribute types for collections, documents, remote objects, anchors, etc.

· CollectionType

CollectionType is an attribute of collections. Its possible values are “Cluster“,
“Sequence”, “MultiCluster” and “AlternativeCluster”, which are all subtypes of the basic
type “Collection” and which each have special features additionally to the normal
collection features.

· Description

You can use this attribute to enter a brief description of the contents of a collection or
cluster. Web clients display this description between the collection’s title and the listing of
its contents if no full collection head (see attribute PresentationHints) has been declared
for the collection.

It is possible to enter different versions of the description in different languages, using the
language prefixes (see Title attribute). In this case, only the description which
corresponds to the selected language is shown. However, unlike the title attribute, it is not
required that you give a description a language prefix.

· DocAuthor and DocDate

These attributes are used to enter the actual author of the document (not the person who
uploaded it) and the actual date the document was created (not the date at which the
document was uploaded to the server).

· DocumentType



75

Hyperwave User’s Guide - Getting Started with Hyperwave Information Server

DocumentType tells you what type (e.g. text, collection, generic, etc.) an object has. This
attribute cannot be changed by the user.

· GOid

The GOid or “Global Object Identifier” is a unique identifier that every Hyperwave object
has. It consists of two 8-digit hexadecimal numbers connected by an underline (“_”)
character. The first uniquely identifies the Hyperwave Information Server which contains
the document and the second uniquely identifies that object on that server. This scheme
makes the GOid for every Hyperwave object in the world unique. The GOid can be used
in many Hyperwave functions instead of the Name attribute. For example, for the
“move” function, a target collection must be entered so Hyperwave knows where to put
the objects. In this case, either the Name or GOid of the collection can be entered.

This number may also be used as a path in the URL. For example, the object with the
GOid 0x811b9908_0x00147a26 can be accessed from any web client using the
URL

http://<server_name>/0x811b9908_0x00147a26

· Hint

Hint is an attribute of anchors. If the anchor is pointing to another server, the value of
Hint is an external URL. If the link is open, i.e. the anchor’s destination object has been
deleted from the server but the anchor itself has not been, Hint stores information about
the object that was removed. This makes it possible for Hyperwave to reconstruct links
once an appropriate object is uploaded to the server. See also the Hyperwave
Administrator’s Guide.

· Host

Host is an attribute of remote documents. Its value is the remote host taken from the
URL that was entered when the object was created.

· HW_HEADER

By default, Hyperwave displays frame documents without the Hyperwave header and
footer. If this attribute type, with the value “yes”, is given to a document, the frame
document is displayed with a header.

· HW_PLAIN

If this attribute type, with the value “yes”, is given to a document, the document is
displayed without the Hyperwave header and footer.

· Keyword

The Keyword field is optional and allows you to associate words of your choice with
objects (collections, documents and anchors) while you are inserting them or afterwards.
These words can be used to search for this object (see page 28) so keywords should be
words which describe the object but are not found in its title. You can add a new keyword
field for each keyword or you can simply enter the different keywords separated by spaces
in one field. If you want to combine more than one word to a single keyword, connect the
words with a hyphen, e.g. “decision-support-systems”.

· License

The value of this attribute is a series of hexadecimal numbers. For example, the License
attribute of Meyer’s 10-volume Encyclopedia on IICM’s Hyperwave Information Server
in Graz has the following value:

0x0000012c 0x00000003 0x00000014

The first of the three hexadecimal numbers specifies the timeout period, which is 5
minutes in our example (hexadecimal 12c is 300 seconds). This represents the length of
time that a user can lock the collection without retrieving documents. The second
hexadecimal number specifies the number of licenses or simultaneous accesses to the
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collection - in our example, 3. The last hexadecimal number specifies the number of
documents a user is allowed to retrieve in a single “grab” of the license. This is a measure
against somebody trying to download the whole collection (of possibly copyrighted
material) and blocking it for a long time for others. In our example, a user may look at 20
encyclopedia entries before having to return it. Thus, the maximum time a single user can
keep the encyclopedia is 5 × 20 = 100 minutes. Also, the time to download the whole
encyclopedia (43,820 documents) is significantly increased.

For the license scheme to work, the License attribute must be given to a collection and
the documents whose retrieval is affected by the license must be in the collection and each
one must contain a reference to the collection (in the encyclopedia example it is named
“ref.m10”) in the “L:” field of the Rights attribute. Thus the value of the Rights field
would look like this:

L:ref.m10

This is done so that every access to a document in the collection is taken into account,
regardless of how it was found (including searching and link following). It is not necessary
to directly access the collection with the License attribute to enable the license
mechanism.

· LinkType

LinkType is an attribute of anchors. Its possible values are “annotation”, for annotation
links, and “inline” for inline images. Normal reference links have no LinkType attribute.

· MimeType

The MIME protocol is used in Internet communications to transmit documents of
varying formats. The protocol handles complexities by establishing a relationship (a
mapping) between the format of a document’s content and the format of the document’s
computer representation. It is used to tell your Web browser how to interpret the content
of a transmitted document. With the proper Helper Application settings and software,
your Web browser can automatically initiate the necessary actions to provide you access
to content transmitted in numerous formats. Thus it is important to set the correct
MIME type when uploading documents to Hyperwave. When uploading documents, you
can let the browser set the MIME type or select a MIME type from a list.

· Name

The value of this attribute can be almost any name you would like to give your document
or collection except for a few restrictions: it must be unique on the server you are
inserting the object into and may not contain any spaces. When naming collections, it is
recommended to use a hierarchical scheme. This means that a collection should be named
according to the collections which it is a member of, e.g. if your home collection is named
“smith” and you want to insert a collection of personal information into it, you might
name this collection “smith/personal”. This naming system helps to avoid attempts to use
names which are not unique.

Names are also used in URLs. For example, to access a document on your server with the
name “smith/papers”, you would enter the URL
http://<my.server>/smith/papers.

· Owner

The value of the Owner attribute is (initially) the user name of the person who created the
object. This user automatically has the right to modify the object. The value of the Owner

field may be changed in order to change the ownership of the document. This can only be
done by the group of system administrators (members of the group “system”) and not by
the owner or by other users who have rights to the object.

· Path

Path is an attribute of remote documents (see page 49 for instructions on how to insert
remote documents). For WWW documents Path is the file name of the remote
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document including its directory path, e.g. if you enter the URL
http://www.server.com/public/info/text1.html for your remote document, Path

is public/information/text1.html. For telnet connections, which are entered
as telnet://user@host, Path is the value of user.

· PLACETemplate

PLACE is a meta-HTML language, which is used to configure the appearance of
Hyperwave’s interface. It consists of standard language constructs such as if-statements,
macro-statements and while-loops and a number of so-called placeholders. Placeholders
make meta-information about the currently shown document and information about the
Hyperwave Information Server accessible and can be of type STRING, NUMBER or
BOOL.

Normally every document on a particular server has the same basic layout which is based
on a set of PLACE templates that are installed automatically with the server, and which
may or may not have been altered by the server administrator. The PLACETemplate

attribute is used to change that appearance for a particular document. To do this, you
need a template which gives documents the desired appearance. The template script must
be uploaded to the server and be given MimeType text/plain. To cause a document
to use the newly uploaded PLACE template instead of the default, you must give the
document the PLACETemplate attribute and enter the Name or the GOid of the place
template as its value. See the Hyperwave Programmer’s Guide for details on programming
PLACE templates.

· Port

Port is an attribute of remote documents. Its value is taken from the URL that was
entered when the document was created, if a port number was included in the URL. Its
value is 80 by default.

· PresentationHints

By default, Hyperwave presents collections as a list of links to their members. Clusters also
have a default presentation. PresentationHints can be used to change this behavior.
There are three possible entries for this field.

· CollectionHead: Normally, when you open a collection, it just displays a list of the
objects it contains and does not display any of the actual documents contained in it. If,
however, you declare one of these documents or clusters as CollectionHead, it is
presented automatically when the collection in accessed. A list of links to the other
collection members is displayed below the document.

· FullCollectionHead: This is similar to CollectionHead in that it causes one document
to be displayed automatically when a collection is opened, but the list of links below the
document is not shown in this case.

· Hidden: The Hidden value is useful for documents contained in clusters. Usually
clusters display several documents simultaneously, but you can use Hidden to explicitly
declare that a certain object should not be displayed. This is useful, for example, when
you have a cluster which contains both a text which contains an inline image, and the
inline image itself. Ordinarily the text (including the inline image) and separately the
inline image itself would be displayed. If you give the image the Hidden attribute, it will
suppress the separate display of the image and only show it within the text.

· Price

The Price attribute is used to implement Hyperwave’s document pricing feature.
Different users and groups can be offered different prices based on the value of this
attribute, which is a series of one or more prices (specified as unsigned 32-bit integers),
optionally followed by a colon and a specification of users and user groups. Each price
declaration is separated by semi-colons.

For example, the value of the price attribute could be:

0x00000064;0x00000050:g iicm,u wonko; 0x00000000:u fkappe
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which specifies that the document should normally be worth 100 units (64 in
hexadecimal), but members of user group “iicm” and user “wonko” get a rebate of 20%
and pay only 80 units (50 in hexadecimal), while user “fkappe” would have to pay
nothing.

· Protocol

Protocol is an attribute of remote objects and has as value the protocol type of the object,
taken from the URL that was entered when the remote object was created. It can have
values such as “http” and “telnet”.

· Quality

This attribute can be given to a document in an alternative cluster. An alternative cluster
is a cluster which contains several different documents, one of which is selected when the
cluster is accessed based on preferences for preferred document type and quality set in the
user record of the current user (see the Hyperwave Administrators Guide). The value of
Quality can be a whole number between 1 and 100, where 100 is the best possible quality.

· Rights

The Rights attribute can only be given to an object or modified by the author of the
object or system users (members of user group “system”). It allows you to give read, write
and unlink access to your objects. “Read access” is permission to see objects and “write
access” is permission to modify objects. “Unlink access” is only meaningful for collections
and gives permission to remove objects from the collection.

By default (that is, when no Rights attribute is present) only the author of the object and
members of the group “system” have write and unlink permissions while all users
(including anonymous users) have read permission. In principle, the Rights attribute
allows you to reduce the set of users who have read access, to enlarge the set of users who
have write access, and to reduce the write access set to a set of users with unlink access.

Its value is composed of read (R:), write (W:) and unlink (U:) permission fields,
separated by semicolons. For each field, the value 'a' means that the author of the object
has access, 'u users' means that the specified users (user names separated by blanks) have
access, and 'g groups' means that the members of the specified user groups (group names
separated by blanks) have access. Each field may appear only once, and within the field,
field values may be separated by commas.

Summing up, syntax is as follows:

R:a,u XVHUV,g JURXSV;W:a,u XVHUV,g JURXSV;U:a,u XVHUV,g JURXSV

where any of the three major fields (R, W or U) can be used or left out as needed and any
of the a, u and g fields can be used or left out as needed. This is made clear in the examples
that follow.

Note: This syntax may seem somewhat complicated, and thus Hyperwave offers you the alternative
of using the Rights Wizard, which lets you easily give read, write and unlink writes to the users and
groups of your choice.

Note that the author of an object and all system users always have read, write and unlink rights
even if it is not mentioned explicitly below.

R:g project_a,u smith

Members of user group project_a and user smith have read permission, only the
author of the object has write and unlink permissions (the write field is not present and
thus the defaults are used).

R:g project_a project_b;W:g project_a

User groups project_a and project_b have read permission, but only group
project_a has write and unlink permissions.

W:g b1 b2;U:g b1

EXAMPLE VALUES FOR THE
RIGHTS ATTRIBUTE
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All users have read permission (default; read field is empty), and groups b1 and b2 are
granted write permission, but only the members of b1 may also remove objects from this
collection (the unlink field is ignored for objects which are not collections).

R:a

Only the author has read (and by default write and unlink) permission.

W:a

This is the default setting that is used when the Rights attribute is not present: everybody
can read, but only the author may write and unlink.

· Sequence

The value of the Sequence attribute is used to specify the order in which objects appear in
the list of members when a collection is accessed. The value of this field should be a whole
number, negative or positive. It is a good idea to leave a gap between the sequence
numbers so that it is always possible to insert new objects between existing ones, e.g. you
should assign only the numbers 10, 20, 30, etc. to the objects. If an object has no sequence
number, it is treated as if it had zero as a sequence number. By default the members are
sorted by sequence number and any which have the same number are sorted by title. A
sequence number is valid for every collection in which an object is contained, thus
changing the sequence number for an object will affect the way it is sorted in all
collections in which it is found. See also the attribute SortOrder.

· SortOrder

This attribute is useful for collections because it affects the order in which the list of
collection members is presented, if the collection is presented in the default way. There
are two different ways of entering this attribute. The first option is to enter a combination
of the characters in the table below, each of which stands for a certain sorting criterion.

Character Meaning

A Author

C TimeCreated

E TimeExpire

O TimeOpen

N Name

S Score

t Type (order: collection, cluster, text, image, film,
audio, scene, PostScript, generic, annotation,
remote)

T Title

# Sequence number

- use the reverse of the next stated sorting criterion

The items are sorted by the first criterion stated and those which cannot be differentiated
by this criterion are sorted by the next criterion and so on. For example, the entry #-T
causes the objects to be sorted by sequence number and those objects which have the
same sequence number to then be sorted by title in reverse alphabetical order. If an object
has more than one title in different languages, the object will be sorted according to the
title in the currently set language.

The default sort order is #T, i.e. objects are sorted by sequence number and then by title if
the sequence number is the same (all objects without a sequence number are treated as if
they had 0 as sequence number).

The second option for entering a value for this attribute has a somewhat more complex
syntax and allows you to sort by any attribute. It consists of one or more groups of three
values, separated by colons and surrounded by parentheses:

’(’<AttributeName> ’:’ <SortType> ’:’ <Order>’)’



80

Hyperwave User’s Guide - Getting Started with Hyperwave Information Server

Note that all three of these fields must be present when using this sorting syntax. Note
also that if more than one such triple is entered, then the objects are sorted first by the
first sorting criterion, and those which cannot be differentiated using one criterion are
sorted by the next.

The fields have the following meanings:

<AttributeName>: The name of the attribute you want to sort by.

<SortType>: This specifies how the value of the attribute should be interpreted. The
following values are possible:

I (Integer): The attribute value is interpreted as a number.

S (String): The attribute value is interpreted as a string.

D (Date): The attribute value is interpreted as a date.

E (Enumeration): The attribute value is interpreted as a string and is ordered according to
the order field.

<Order>: Specifies the sort order. <Order> can have as value “+”, meaning the values are
sorted in increasing order, “-“, meaning the values are sorted in decreasing order, or a list
of values and placeholders.

If a list of values and placeholders is entered here, the attribute values are compared with
the values specified and sorted accordingly. The specified values can also be just a prefix of
the attribute value. It is possible to use the placeholder %lang in order to access the
user’s language preference.

Examples

(Title:E:ge;en;fr)

Sort by title, where objects with German titles come first, followed by objects with English
and then French titles. Objects with titles in other languages are not sorted in any special
order.

(Sequence:I:+)(TimeModified:D:-)(MIMEType:E:image)

Sort increasingly by sequence numbers, where objects with the same sequence number are
sorted such that the most recently modified documents are first, and finally by MIME
type if the documents are not distinguishable by either of the first two criteria.

(Title:E:%lang;en;fr)

Sort by title, where the objects of the language declared by the user come first.

(Title:E:ge)(Title:S:+)

First the objects are sorted such that objects with a German title come first, then the
objects are further sorted alphabetically by title. Note that for the Title attribute as well as
for all other attributes that can be given to an object multiple times, that if the same
attribute is sorted by more than one criterion, the same instance of the attribute is always
used. This means in this case that all objects with German titles come first after sorting by
the first criterion, then when these objects are further sorted alphabetically, they are sorted
by the German title and not by a title in some other language.

· Subdocs

Subdocs is an attribute of all collection types and tells you how many documents are
contained in the collection either directly or indirectly in its subcollections. Because
documents can be contained in more than one collection at the same time, the value of
Subdocs may be larger than the actual count of different documents in the collection and
its subcollections. This attribute is maintained by the server and users cannot change its
value.

· TAnchor

TAnchor is an attribute of anchors, and can have as value either “Src” for source anchors
or “Dst” for destination anchors.
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· TimeModified and TimeCreated

TimeModified tells you when an object was last modified, i.e. the last time when either
the object or its attributes were modified. This attribute is not under the control of the
user but is maintained by the server. TimeModified is indexed, which means that it is
possible to quickly find objects according to when they were last modified.

TimeCreated tells you when an object was created on the server. Like TimeModified, it
is maintained by the server and is indexed.

· TimeOpen and TimeExpire

These attributes are used to make an object on the server visible only during a certain
range of time. TimeOpen designates the time at which the object becomes visible and
TimeExpire the time when it can no longer be seen. The object is always visible to its
owner and system users, regardless of the entries in these fields. The entries must be times
and are entered in the IRUP

[yy]yy/mm/dd hh:mm:ss

You need only specify the time to the desired accuracy, thus 97/01/03 is a perfectly
valid entry and is equal to January 3, 1997 at 12:00 am.

· Title

Hyperwave objects may be given more than one title, but each title given must be
declared as being of a different language. Titles can be given either when the object is
being inserted or later by editing its attributes. In either case a menu where you can select
a language appears after the field where you enter the title. Note that if you give objects
multiple titles and you sort the objects by title, only the titles corresponding to the current
language preference will be considered.

Please note that if you do not have JavaScript, the menu mentioned above doesn’t appear
and the language must be entered with the title. This is done by entering a two-letter
language prefix, followed by a colon, followed by the title itself. All language prefixes
currently in use are listed below.

Language Abbreviation

English en

German ge

French fr

Italian it

Spanish sp

Japanese jp

Thus, some possible entries in the Title field when not using JavaScript are:

· en:The City of Graz

· ge:Die Stadt Graz

· sp:La Ciudad de Graz

· Type

Type distinguishes between anchors and other documents. For anchors, Type is
“Anchor” and for all other objects, e.g. collections, texts, remote documents, etc. it is
“Document”. This attribute cannot be changed by the user.
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2.6� HYPERWAVE ODMA

ODMA lets you edit or upload documents using ODMA compliant applications on the
Hyperwave Information Server. To do this, Hyperwave ODMA must be installed on your
computer (see the Hyperwave Installation Guide). You must have Word ‘97 to use Hyperwave
ODMA. For a detailed description of ODMA see http://www.aiim.org/odma/odma.htm or
http://www.activedoc.com/odma/index.htm. For a list of ODMA compliant applications
look at http://www.activedoc.com/odma/odmaapp.htm.

2.6.1� INSTALLING ODMA

ODMA can be installed with the installation package for the NT Hyperwave Information Server.
See the Hyperwave Installation Guide for details.

In order to install ODMA, you must have:

· Windows 95 or Windows NT 4.0

· Microsoft Internet Explorer 4.0 or higher

2.6.2� EDITING MICROSOFT WORD DOCUMENTS IN
HYPERWAVE

1. Start Microsoft Word.

2. Select File→Open. The Hyperwave ODMA Select File window appears (see Figure 47).
Click on the “Classic File Open” button if you want to open a file from your file system,
or continue on to the next item to use ODMA to edit a file in Hyperwave.

3. You can either choose from the list of servers in the Select File window, or you can select
the item “add NEW entry”, to add a new server to the list of favorites (see Figure 46). In
the form you must enter a nickname for the server, its URL and port, the collection you
want to access on the server, and your user name and password for that server.

 If you select an item from the list of servers, you will go directly to the server and
collection specified in that item. It is then possible to browse through the list of
Hyperwave objects displayed and to select a Word, HTML, or plain text document to be
edited in Word.

4. When you are finished editing, save the text with File→Save. This will upload the
changed text back to the server.

INSTALLATION
REQUIREMENTS
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Figure 46: Adding a new server to the list of favorites

Figure 47: The Hyperwave ODMA Select File window
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2.6.3� UPLOADING DOCUMENTS WITH ODMA

HTML, plain text and Word documents can be uploaded to the server as follows:

1. Start Microsoft Word.

2. Select File→Open. The Hyperwave ODMA Select File window appears (see Figure 47).
Click on the “Classic File Open” button, and open a file from your file system.

3. After you have loaded a file, select File→Save As. The window in Figure 48 appears.
Name is optional, and can be used to give the document a MIME type as well as a name
(see below). You must enter a Title and select a language from the list (default is English).
Rights are optional (see page 78 for syntax). Click on the “Enable version control”
checkbox if you want the document to be checked in after it is uploaded. Select the server
and collection where you want to insert the document using the list.

4. Click on the “Save As” button.

The Name attribute can be used to give the document you are uploading a particular MIME type.
By default, all documents uploaded to the server from Microsoft Word using ODMA are stored on
the server as Word documents. By giving the Name a value with a particular extension, you can
also upload HTML and plain text documents and give them the correct MIME type on the server.
For example, if you give a text document the name “home.txt”, the document will be given the
Hyperwave MimeType “text/plain”. Likewise, a document which is given a name which ends in
“.htm” or “.html” will get the MimeType “text/html”.

Figure 48: Uploading a document to the Hyperwave Information Server

NAME
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2.6.4� EDITING VERSION CONTROLLED DOCUMENTS

If the Hyperwave document you want to edit with Word is version controlled, then it is
automatically checked out when you select it for editing as long as you have write rights for it.
When you save it, it is uploaded to the server but remains the experimental version, i.e. it is not
checked in. When you close the document in Word, you are prompted with the question of if you
want the document to be checked in again or not. Click on “Yes” to check in the document.

2.7� HYPERWAVE PUBLISHING WIZARD

The Hyperwave Publishing Wizard (HPW) is a tool designed to make the process of publishing
documents to a Hyperwave Information Server as simple as possible. It plugs into Microsoft’s Web
Publishing Wizard, which means that you can publish documents directly from most new
Microsoft programs. You can also upload whole directory trees that you have prepared on your
local disk to Hyperwave with just a few mouse clicks.

Figure 49: The Web Publishing Wizard

2.7.1� HOW TO USE HYPERWAVE PUBLISHING WIZARD

After successful installation, the Web Publishing Wizard inserts itself into the “send to” popup
menu of the Microsoft Explorer. When you start the Web Publishing Wizard you are guided
through the process of uploading files or directories to Hyperwave Information Server with the
Hyperwave Publishing Wizard.

This is done as follows:
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1. In the Microsoft Explorer, hold down the right mouse button on the file or directory you
want to upload. On the menu that appears, select “send to/Web Publishing Wizard”. This
starts the Web Publishing Wizard.

2. Once you have started the Web Publishing Wizard, click on “Next” to display the screen
in Figure 49. You can select one of the servers on the list and upload your documents to it,
or enter a new one. If you want to enter a new one, continue with the next step.

3. Click on the “New” button to start entering information about the server. In the window
that appears, enter a descriptive name for the server. The server name and all other
preferences you enter will be saved under that name for future use, i.e. you will be able to
select it from the server list in the Web Publishing Wizard so you can proceed quickly
through later uploads with the same preferences.

4. Click on the “Advanced” button. In the window that appears, select “Hyperwave Server”
from the list. This invokes the Hyperwave Publishing Wizard.

5. In the next window, enter the URL of the server you want to upload to.

6. After you click on “Next”, the Hyperwave Publishing Wizard appears (see Figure 50).
This window displays the descriptive name and the server name you entered earlier in the
Web Publishing Wizard, as well as the default Hyperwave port number. Do not change

the descriptive name or server name.

7. In the next window you must enter your Hyperwave login name, password, and the name
of the collection you want to upload your documents to.

8. The next window lets you decide what to have the Hyperwave Publishing Wizard do if
you are publishing documents which already reside on the server.

9. The Access Rights window allows you to set read and write access for the documents you
are uploading. For each kind of right, you can choose to give it to yourself only, to the
Hyperwave groups you specify, or to all users. When giving rights to groups, you may
enter one or more groups in the field, separated by spaces.

10. In the Language window, select the desired language for your documents.

11. Select the desired options in the Version Control window. These options are explained
below.

12. Click on “Finish” to start the uploading process.

Note: Files which are uploaded to Hyperwave using the Hyperwave Publishing Wizard must not have
spaces in their file names.
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Figure 50: The Hyperwave Publishing Wizard

You may also invoke the Wizard by dragging the file or directory to be published onto the Web
Publishing Wizard icon (after you have placed it on your desktop), if you prefer. Also, some
programs (like FrontPage) explicitly offer a “publish” button, so that you can upload documents
directly from the program.

Figure 51: Enabling version control with HPW

The Hyperwave Publishing Wizard can be used to enable automatic version control for your
documents.

There are three checkboxes in the Version Control window. Clicking on the first checkbox
activates the other two. These two options work as follows:

VERSION CONTROL
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Forced check in: This option only affects documents which are not already version controlled.
With this option, new documents are uploaded, checked in and then checked out. Documents to
be replaced are checked in, checked out, and the experimental version is replaced.

Commit version: Specifies that version controlled documents are to be checked in as a last step.

See also page 68 for more information about version control.

The combination of options you select affects your documents according to the following table.

Options New document Document exists, not

version controlled

Document exists,

version controlled

none create new
document, no
version control

replace document, no
version control

error

version control create new
document, no
version control

Replace document, no
version control

check out document,
replace experimental
version

version control,
forced check in

create new
document, check in,
check out

Check in, check out,
replace experimental
version

check out document,
replace experimental
version

version control,
commit version

create new
document, no
version control

Replace document, no
version control

check out document,
replace experimental
version, check in

all create new
document, check in

Check in, check out,
replace experimental
version, check in

check out document,
replace experimental
version, check in

2.7.1.1� EXTENDING HPW’S RECOGNIZED FILE TYPES
The HPW recognizes certain standard file types and does not upload file types it does not
recognize. You can extend the file types recognized by using the registry editor. Start the registry
editor (regedit.exe) in the command line. For every file extension you wish to add create a
“key” entry in:

HKEY_CURRENT_USER→Software→Hyperwave→Publishing Wizard→Filetypes

The name of the key entry must be the file extension of the file type you want to add. Within this
new key create the string values “Filetype” and “Mimetype” and add the appropriate values (e.g.,
key entry: “exe”, Filetype= “Generic”, Mimetype= “application/octet-stream”).

2.7.1.2� ADDING CUSTOM ATTRIBUTES
If you need a set of custom attributes which should be attached to every file you upload to a
specific site follow the steps below.

Start the registry editor (regedit.exe) in the command line. For every site you have created
you will find an entry under:

HKEY_CURRENT_USER→Software→Hyperwave→Publishing Wizard→Sites

Example:

You have a site entry with the nickname “HyperwaveSite1”

(HKEY_CURRENT_USER→Software→Hyperwave→Publishing Wizard→Sites→
“HyperwaveSite1”) and you want to add the custom attributes “hint=on” and “speed=123”.

1. In the registry editor activate the key entry “HyperwaveSite1” (click on it) and press the
right mouse button. In the menu that appears, select “NEW” and “Key”. Insert a new key
with the name “Attributes” (case sensitive!).
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2. Activate the new key entry (click on it) and again press the right mouse button, select
“NEW” and “Key”. Insert a new key with the name of the new attribute you want to add
(in our example “Hint”).

3. Activate the new attribute entry (click on “Hint”) and press the right mouse button. Now
insert a new string value (“New” → “String Value”). The name of the string value must be
“Value” (case-sensitive) and for the data enter the value you want to assign to the
attribute (in our example “on”).

Repeat steps 2 and 3 for every attribute you want to add.

2.8� HYPERWAVE VIRTUAL FOLDERS

Hyperwave Virtual Folders is a tool designed to make the process of handling documents on a
Hyperwave Information Server as simple as possible. It plugs into Microsoft’s Explorer, which
means that you can navigate and edit documents directly from the standard Microsoft Explorer
program. You can also upload whole directory trees from your local disk or download them to
your disk with just a few mouse clicks.

2.8.1� HOW TO USE HYPERWAVE VIRTUAL FOLDERS

After successful installation, Hyperwave Virtual Folders inserts itself into Microsoft Explorer’s
Desktop. When you first open Hyperwave Virtual Folders, you only have the possibility to add a
new server entry for further exploring.

Figure 52: First View

2.8.1.1� HOW TO ADD A NEW SERVER
Click on the “Add new server” icon to start the Hyperwave Site Wizard in order to add a new
server to the Microsoft Explorer’s view. The Wizard (see Figure 53) guides you through this
process, prompting you for information such as the server address, port number, user name and
password, firewall proxy settings, etc. After you finish making entries with the Wizard, the new
server should appear under Hyperwave Neighborhood in the Explorer.
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Figure 53: The Hyperwave Site Wizard

2.8.1.2� DEFAULT SETTINGS
When opening the view for a Hyperwave Folder you can change default properties with the View
menu.

Figure 54: The View menu

With this dialog you can set your preferred displaying language. Hyperwave Virtual Folders
displays titles in the preferred language if that language is available.

These settings are used when uploading files via drag & drop.

2.8.1.3� NAVIGATING WITH HYPERWAVE VIRTUAL FOLDERS
Navigating on a Hyperwave server with Hyperwave Virtual Folders is as easy as browsing through
your local file system. You can open and close any collection/folder by double clicking on the
name or icon. If you double click on any document on the server the document will be
downloaded to the default Windows Temporary Directory. After downloading the file to the local
drive the associated application is started to view the file. There is a special behavior for HTML
objects. Instead of downloading the file your default Web browser is started with the URL
Location of the clicked document.

Note: The downloaded temporary files are not automatically deleted, so it is recommended that you
frequently clear your temporary directory.

LANGUAGE PRIORITIES

UPLOAD PROPERTIES
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If you have the appropriate access on the server you also have the possibility to change objects on
the server. You can use the commands available on the context-sensitive popup menu (see Figure
55) which appears when you click with the right mouse button on any object.

Figure 55: Popup menu

2.8.1.4� FUNCTIONS IN THE POPUP MENU
The context sensitive popup menu offers you several functions for manipulating data on the
server. The menu contains the following items:

· New: Allows you to create a new collection or cluster on the server.

· Delete: Allows you to delete a document or recursively delete a collection. If an error
occurs while deleting the files, the delete operation will stop at the location where the error
occurred.

· Modify: Allows you to recursively change the attributes of a collection (see page 91).

· Checkout: This command recursively checks out the documents contained in the current
folder.

· Checkin: This command recursively checks in the documents contained in the current
folder. Before check-in, you are given the option of entering a comment for the version,
and to force check-in of documents which are not already version controlled. You can
increase the minor version number for the objects, e.g. 4.2 becomes 4.3, or the major
version number, e.g. 4.2 becomes 5.0.

· Properties: Allows you to change the attributes of the current object or use version control
on it (see page 92).

· Reload: Updates the contents of the folder shown in the Explorer according to the current
state of the server.

The “Modify” function allows you to recursively change the attributes of a collection and its
contents. When you select the “Modify” item, the “Modify Attributes” window appears (see Figure
56). Use the “Add”, “Remove” and “Change” buttons to make a list of the attributes you want to
add, delete and modify. Click on “OK” to apply the changes.

MODIFY
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Figure 56: The Modify Attributes window

This option allows you to modify the attributes of the selected object as explained below.

Figure 57: Object properties

PROPERTIES
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· To change an attribute value, click on the value (only the attributes that have a white
background can be modified) and enter the new value and then click on the “Apply”
button.

· To delete attributes, select one or more attributes and click on the “Delete” button and
then the “Apply” button.

· To add a new attribute, enter an attribute name and value in the appropriate fields (see
Figure 57) and click on the “Add” button and then the “Apply” button.

Figure 58: Version control with Virtual Folders

Click on the “Version Control” tab to check in or check out a document or revert to an older
version of the object (see Figure 58). Just click on the button to execute the specific command.
Before reverting you should enter a valid version in the edit field next to the button.

When checking in an object a dialog appears where you can enter a version number and a
description for the new version. If you leave the version number blank it is automatically
incremented by the server.

Note: Sometimes the view is not correctly updated after the status of an object is changed. If this
happens it is recommended to refresh (F5 key) the Explorer view.

2.8.1.5� EDITING DOCUMENTS WITH HYPERWAVE VIRTUAL FOLDERS
Documents can be edited with Hyperwave Virtual Folders in much the same way files on the local
hard disk can be edited.

For modification of documents on the server to work, the application used for editing must use
the Windows common dialogs for load and save. It is also necessary that the Hyperwave
Document Spooler is installed and running when editing the documents.

VERSION CONTROL

REQUIREMENTS
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Double-click on the document you want to edit and it will appear in the appropriate editor.
Modify the document and save it. The document is automatically uploaded to the server by the
spooler. A second possibility for editing documents through Virtual Folders is to start an
application and load a document into it from a Hyperwave Information Server by navigating to
Virtual Folders in the "Open" dialog (this only works if the application uses the standard Windows
open and save dialogs). Again, the document is copied to the temporary directory and checked
periodically by the spooler for changes.

Lastly, it is possible to upload new documents to the server by selecting "Save As" in applications
that use the standard Windows open and save dialogs and navigating to the Virtual Folders.

The Hyperwave Document Spooler is automatically installed with Hyperwave Virtual Folders and
is inserted in the “Startup” menu so that it is automatically started each time you start your
computer. If you take the spooler out of the “Startup” menu, you must start it by hand if you want
to edit documents on the server using Virtual Folders.

The spooler works as follows: when you retrieve an object through Virtual Folders to edit it, the
file is opened in the corresponding application and copied to a particular directory. The spooler
checks this directory periodically for changed files and if it finds one, it uploads it to the server. An
icon with a blue and white arrow is displayed in the taskbar (in the lower right corner of the
screen) when the spooler is running. If the spooler is active, i.e. it is uploading a document to the
server, the icon is also active.

You can check the status of the spooler with a left mouse click on the spooler icon. A window
appears which shows what the spooler is currently doing, e.g. uploading a document to the server.

Figure 59: Spooler properties window

A right mouse click on the spooler icon displays a context-sensitive menu. The menu contains the
following items:

· About: Displays the version number of the Hyperwave Document Spooler.

· Properties: This item allows you to select one of two further items:

· Spooler: This item displays a dialog that allows you to change spooler settings (see
Figure 59). Here you can change the temporary directory (the directory that Virtual
Folders downloads the files to and which the spooler checks for modified files), and
adjust the spooler delay in milliseconds. Furthermore, it is possible make settings which
prevent the spooler from uploading files that end or begin with strings you specify. This
can be used e.g. to prevent the spooler from uploading temporary (.tmp) files.

· Temporary Files: This allows you to set two further options for the spooler. You can
tell the spooler whether or not to put deleted files in the Windows Recycle Bin when

EDITING DOCUMENTS

UPLOADING DOCUMENTS

HYPERWAVE DOCUMENT
SPOOLER

SPOOLER SETTINGS
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clearing the workspace, and whether or not to show a Windows progress dialog when
deleting these files.

· Empty Workspace: This allows you to manually delete the files from the temporary
directory.

· Close: This lets you close the spooler. You have the choice of logging off (in which case the
spooler is closed but is started again at the next reboot) or closing the spooler (in which
case it will not be started again at reboot).

2.8.1.6� DRAG & DROP
Hyperwave Virtual Folders lets you move, copy or link objects on a server easily with drag & drop.
Drag & drop also works between different Microsoft Explorer windows.

There is keyboard support for the drag & drop functionality, meaning that you can copy an object
with CTRL-c and paste it with CTRL-v.

On drag operations to or from the local drives only the copy operation is performed. This means
that whether you use the “copy” or the “move” function, data is not deleted from the Hyperwave
Information Server.

It is important to note that collections that have been downloaded from the Hyperwave Server
using drag & drop must be uploaded in the same configuration. For example, let us imagine that
you download a collection Collection1 which contains collections Collection1.1,
Collection1.2 and Collection1.3, and Collection1.3 contains files
File1.3.1 and File1.3.2. Even if the only changes you make are to File1.3.2,
you must reload the collection to the Server in its entirety. If a single file is uploaded instead of
the whole collection, the links will not be able to be updated. Obviously, it is possible to download
single files from the Hyperwave Server, if you know that you only want to make changes to one
file.

Note that when downloading files from a server to the local file system all files are downloaded to
the Windows temporary directory first and then they are transferred to the destination directory.
Whether the files are deleted from the temporary directory afterwards depends on the drag & drop
operation you chose. If you chose “move”, the files are deleted, and if you chose “copy”, the files
are not deleted. Thus it is recommended that you make “move” operations when transferring to
the file system so that the files do not reside on your hard disk in duplicate.

When downloading from a server, .hmi files are automatically created. These files contain
attribute information for the documents and collections that were downloaded so that when they
are uploaded, they get the correct attribute information. See the Hyperwave Administrator’s Guide
for more information about .hmi files.

2.8.1.7� RELOAD
If any changes are made on a server, the Hyperwave Virtual Folders are not notified automatically.
Thus it is necessary to manually upload the data shown in the Explorer. When using the ‘Reload’
operation the currently selected folder will be reloaded from server.

Sometimes if there are any inconsistency in displaying the objects it is recommended to reload and
after that to refresh the Explorer.

2.9� NETSCAPE GOLD SUPPORT

Hyperwave offers full Netscape Gold support, which means you can use Netscape's editor to
publish documents to Hyperwave.

There are a few things you should note when using Netscape Gold to publish documents with
Hyperwave.

· There are problems when entering the location to publish to and the user name and
password when publishing documents. You are prompted for this information after

KEYBOARD SUPPORT

DRAG & DROP BETWEEN
THE SERVER AND THE

LOCAL FILE SYSTEM

.HMI FILES
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initiating the publishing process using File/Publish or the Publish button in the Publish

Files window. In the lower half of this window you must enter the location to publish to.
Enter the complete name of the Hyperwave Information Server (preceded by http://)
followed by a slash and the collection name where you want to publish the document, e.g.
http://www.iicm.edu/~mycollection. Below this field are the user name and
password fields. Do not enter anything in these fields or the publishing procedure will not
work. You will be prompted for your user name and password after you click on OK.

· It is recommended that you enter a title for the file you are publishing, using the menu item
Properties/Document and selecting General, where you will find a field for entering the
title. If you do not do this, the title of the document will be the same as the name of the file
you are uploading.

2.10� JAVA APPLETS AND HYPERWAVE

Java is one of the most exciting recent developments in the World Wide Web. It promises to solve
many problems by being platform independent and offering new perspectives on interaction and
information presentation over the Internet.

Java and JavaScript are supported by Hyperwave.

2.10.1� INSERTING JAVA CLASSES

Java classes must have the DocumentType “Program” and a Name attribute to be referenced
from within an HTML document. Java classes can be inserted into Hyperwave with a web browser
as follows:

1. Press the Edit button on top of your screen (in default layout).

2. From the options that appear choose Insert Document.

3. In the form that appears you may insert the necessary information, like Collection (name
of the collection where you want to insert your applet), Title, Name, File (in some
browsers you can browse for file names). From the listbox choose the attribute
DocumentType and type in Program as value. The Name attribute consists of
codebase/classname, for the example below Name is mydir/java/xyz.class.

4. Commit your entries by clicking on Insert Document.

2.10.2� RUNNING JAVA

To run Java a reference must be included in a HTML document following the pattern:

<applet codebase="/mydir/java" code="xyz.class">

<param ....>
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3 APPENDIX A

3.1� HYPERWAVE COPYRIGHT NOTES

The software on this CD is copyright protected. Some packages like Perl are protected by the GNU public license. This license
requires the inclusion of the source code for the distributed packages. For these programs the source code can be found in the
“<path_to_CD>/unix/src” directory, the source code includes also the exact text of the license.

In addition this CD contains the Acrobat Reader from Adobe to display the PDF documentation. The official copyright statement
follows:

Acrobat  Reader Copyright  1987-1996 Adobe Systems Incorporated.

All rights reserved. Adobe and Acrobat are trademarks of Adobe Systems Incorporated which may be registered in certain
jurisdictions.

Hyperwave, the Hyperwave logo and Hyperwave Information Server are trademarks of Hyperwave Software Inc. Hyperwave
Information Server, Copyright 1998 Hyperwave Information Management, GmbH. All rights reserved.

3.2� NETSCAPE COPYRIGHT STATEMENT

Portions © Netscape Communications Corporation 1996, All Rights Reserved

3.3� BERKELEY SOFTWARE COPYRIGHT

Copyright 1991, 1993

The Regents of the University of California.  All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following
conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following
disclaimer in the documentation and/or other materials provided with the distribution.

3. All advertising materials mentioning features or use of this software must display the following acknowledgment:

 This product includes software developed by the University of California, Berkeley and its contributors.

4. Neither the name of the University nor the names of its contributors may be used to endorse or promote products derived
from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED
WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND
FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS
BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA,
OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER
IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
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